Reordering items of an outline

Hello friends,

Things I have tried

I’m trying to move an item (and its nested sub items) up or down an outline.
I’m using the Outliner plugin and the shortcut cmd+opt+up or down.

When I’m doing so, it only move the items and not the nested items under it.

What I’m trying to do

I’m trying to move an item AND the items nested under it, up or down an outline.

What am I doing wrong?

Here’s a good way to do it:

  1. Open the right-sidebar outline.

  2. You can drag headers up and down, and any nested subheaders will automatically follow.

Unfortunately, this seems to only works for rearranging H1, H2, H3, etc?

I don’t use that plugin but there are two ways you can do it as built-in Obsidian functionality that are pretty simple:

Step 1. Collapse the item you want to move so that everything you want to move is on one line. The carat in the gutter will be pointing right (“>”) to show it’s collapsed, and there will be a “…” at the end of the line for the same reason.

Step 2. Select the whole line, either with mouse or keyboard.

Step 3. This is where you have two options. One, you can cut (Ctrl-X or Command-X) the line and paste it where you want it, or, Two, you can drag and drop the selected line where you want it. Everything will be moved, and the group will be expanded to show everything has been moved.

1 Like

Thank you for your help!
This is the closest to answer my question, but it still doesn’t work very well.

If I try to drag and drop the line in an existing outline, it messes it up completely.

Am I the only one bothered by this?
One of the important part of an outliner is to be able to easily reorder bullet points! :confused:

Not sure what I’m doing wrong; I can’t believe that it’s how it’s supposed to work.

I installed the Outliner plugin to test this, and it seems to be working for me. If I start with a simple outline:

image

I then position the cursor at the line “1”, and type CTRL-SHIFT-DOWN (the default hotkey for “Move list and sublists down”). The entire “1” section is now below “2”:

image

Is something different happening when you follow these steps? Or maybe I misunderstand the problem?

Craig