Rendered code blocks, mathjax, callouts, tables are not expanded when using VIM mode

Steps to reproduce

Write an equation in display mode. E.g.

some text
$$\text{an awesome equation}$$
some other text

Then, when using vim keybinding in command mode, once the equation has been rendered, there seems to be no way to edit the equation. Moving towards the equation just skips it entirely, rather then unrendering it and allowing to edit its source code. If using insert mode, I can move right from the line above and then the equation goes in edit mode, but there should be a way to also do this without going in insert mode, which kinda defeats the purpose of using vim style.

Here’s a video to hopefully better illustrate what I mean:


Notice how the cursor jumps over the equation without showing its source code, unless I’m using insert mode (you can notice how the cursor icon changes before the latex source becomes visible).


  • Operating system: Windows 11
  • Debug info:
	Obsidian version: v0.13.14
	Installer version: v0.13.14
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Safe mode: on



This same bug exists for rendered HTML blocks and the new callouts feature.


Related Bug


As of 0.14.1 with Live Preview rendering markdown tables, basic hjkl navigation in vim mode skips over the table block as it does with other rendered blocks (html, callouts, math, etc). To see the table markdown, have to go into visual or insert mode.

1 Like

This should be fixed in 0.14.3.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.