"Renaming" notes into subfolders doesn't work on Mac

What I’m trying to do

I use Obsidian across multiple devices (Windows, Linux, and Android). For the sake of demonstration, let’s say my vault is found at ~/vault and within the vault I have a folder foo.

One nifty workflow I frequently use is, when making a new note, creating an untitled note (with Ctrl-N), and then subsequently renaming it from Untitled to foo/bar. As I am typing the filename, I get a warning that Obsidian does not support the slash character in filenames. However, when I finally hit enter, the note automatically renames to bar and gets moved into the foo subfolder.

Recently I have started using Obsidian on a Mac and I find that this method doesn’t work. When I type foo/bar and hit return it just automatically renames the note back to Untitled and doesn’t move it. I am able to workaround this by manually moving the note where I want to, or by creating a new note directly from the “open note” window (Cmd-O), but I think it is a useful feature so I’m wondering why Mac alone seems to not support it?

Thanks for any insight!

CMD O

foo/bar

should work on a Mac.

EDIT: You already know about this. I should learn to read!

Good question! I hadn’t heard you could do that — there’s a chance it might not be intended.

Might not be. A friend thinks it may be a filesystem issue since Apple filesystem technically allows / even though Obsidian doesn’t – and in other OSes there is no ambiguity that the slash is a subdirectory…

The only illegal character in a MacOs file or folder name is the colon. Windows is much more restrictive. See: Illegal Characters on Various Operating Systems | Knowledge Base

[Edit: I answered the totally wrong question, sorry.]

I don’t know how accurate that source is — its says ”File and folder names are not permitted to begin with a dot”, which is untrue.

1 Like

I think they probably mean ordinary visible folders of the kind that most users will create. Personally, I’ve been using Macs since 1993, and I don’t think I’ve ever had a reason to create a hidden folder – which doesn’t mean that others will not have a reason for doing it :grinning:

Ah, you’re right — i just looked again, and the examples section below is clearer. I agree that normal users shouldn’t use hidden folders, but that very different from “forbidden” or “illegal file system characters”.

Agreed, that’s definitely incorrect. But I wonder if maybe it meant specifically when “migrating certain files and folders from OS 9 to OS X”.

Anyway, I’m curious about the original topic. Can you test the slashes? It’s working fine for me, sorting into folders. (Sandbox vault too, so it isn’t a plugin I forgot.)

I see the same behavior as the original post — renaming with a slash doesn’t work, in my vault or in sandbox. I’m still on Obsidian 1.0.3, on MacOS 13.1.

@rigmarole , On MacOS Mojave, 10.14.6, with Obsidian 1.1.9 (installer 1.0.0), it also reverts back to “Untitled” if trying to add a slash into the name.

Tested both in the file explorer, and in the note title. And both in my test vault (with plugins and so on), and in the sandbox vault. Same result everywhere. It reverts back to “Untitled” with the aforementioned error message.

whoops… I didn’t notice until you replied. I was replying about Ctrl-O. I didn’t notice the “Renaming” in the topic. I even missed eightning say the same thing.

Sorry everyone!! Yeah it doesn’t work for me either.

1 Like

Yeah I am on Ventura 13.1, Obsidian 1.1.9. Below is my debug info:

SYSTEM INFO:
	Obsidian version: v1.1.9
	Installer version: v1.1.9
	Operating system: Darwin Kernel Version 22.2.0: Fri Nov 11 02:03:51 PST 2022; root:xnu-8792.61.2~4/RELEASE_ARM64_T6000 22.2.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: Everforest v0.0.0
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 18
	Plugins enabled: 14
		1: Citations v0.4.4
		2: Advanced Tables v0.17.3
		3: Periodic Notes v0.0.17
		4: Todoist Plugin v1.9.0
		5: Admonition v9.0.3
		6: Graph Analysis v0.15.4
		7: Quick Latex for Obsidian v2.3.3
		8: Meld Calc v1.0.2
		9: Excel to Markdown Table v0.4.0
		10: Tabout v1.0.0
		11: Natural Language Dates v0.6.1
		12: Calendar v1.5.10
		13: Rollover Daily Todos v1.1.3
		14: Vantage - Advanced search builder v1.4.2

RECOMMENDATIONS:
	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

As a workaround for now, you could create notes via Quick Open (Cmd+O), where the folder trick works on Mac.

Agreed, I see no other option for now. Not really a big deal at all. Just odd because of the muscle memory of creating a new note → renaming it, which happens to work on every other device I use :slight_smile: