Rename vault to a a previous vault name

What I’m trying to do

I am trying to rename a new vault to the same name I have used for a previous vault.

Things I have tried

I have followed the steps to delete a vault outlined by other discussions on the forum. When trying to rename the vault it comes up with the message “There is already a vault with this name”. Thinking that Obsidian tracked the vault names in the .obsidian files, I went through and deleted these - this did not resolve the issue. Further, there is now no longer a file with the name I would like to choose for my new vault. In fact, I cannot even create a folder with that name in my file explorer (comes up with a file with that name already exists).

System Details

Apple MacBook Pro 2021 Model (M1 chip) running Sonoma 14.3

Obsidian version 1.5.8

Any help would be greatly appreciated. Also let me know if there is a known solution to this issue on another thread - I’ve had a look myself yet couldn’t find anything.

You could try this if you haven’t yet:

  1. Remove the previous vault(s) from the vault switcher list:

  1. Rename the vault folder to the name you want using the macOS Finder.
  2. Back in the vault switcher window → Open folder as vault the folder you just renamed.

That might work.

Hey ariehen,

Thanks for your reply. I have performed the “Remove from list” operation on all my current vaults, although the issue still persists. Additionally, I cannot create a folder with the filename I would like to use - macOS finder instructs me that I cannot, despite there being no file with that name on my system.

Obsidian just works on top of folders & files on your disk. If the Finder is preventing you from doing something, it’s an OS file system issue that you’ll have to investigate.

That sounds odd. Can you post a screenshot of this happening in Finder?

What’s the path where it’s happening? What kind of filesystem is it? Is this in iCloud, on a NAS, a local folder, something else? I think there is some missing information here.

1 Like

Could you tell us the filename which is denied? Maybe it just contains illegal characters or something like that.

2 Likes

Hey Rigmarole,

I would like to preface this by saying that the issue seems to have resolved itself - I have now renamed the vault successfully. The file system is the default Apple file system. The file was located in my home directory (no NAS or icloud, stored locally).

Ordinarily I would put this down to restarting my computer, however I had already tried this before posting here. Thank you for your interest in helping me to resolve it though!

1 Like

The filename I wanted to use was MAXIM (my name) and the file name I was using was MAXIM_STUFF. As I mentioned in my reply to Rigmarole, the issue has since resolved itself of its own accord. Thank you for taking the time to assist me in fixing it.

I suspect you were right in this assessment - the OS (and hence Obsidian) is now allowing me to change the filename to the desired name, although I am unsure what I have done to change this. Thank you for your support in my issue.