Regular image embedding syntax

Hi guys!

Really pleased to discover Obsidian and join this community.
It looks like I finally found the best alternative to Joplin.

Since having mobile apps is in the long-term plans, I decided to use 1Writer iOS application - for having my notes synced via WebDav. And this worked like a charm!
So happy about that. Even tags are recognized by 1Writer and being displayed consistently.

However, I just realized that there is an issue with attaching files in specifically Obsidian’s way as ![[image.png]] - which obviously is not recognizable by 1Writer.

Based on the mentioning (in the Help Vault) of the fact that ![Image](link.png) works for embedding images, as regularly with the general Markdown syntax, I wonder - is it possible to make it work in Obsidian some time soon? It would be so great to have this syntax work as well.

2 Likes

It’s already possible in obsidian, but you should specify the complete path to an image, rather than just it’s name as with the ![[image.png]] syntax, so that other markdown editors and renders can find the image.

1 Like

Thanks for mentioning that!
It worked out just fine.

Do you perhaps know - is it possible to switch to automatically use the
![](../Attachments/image.png) syntax for embedding images?
Specifically when the image was pasted from the clipboard.

Or it’s more kind of feature request?

2 Likes

I have this exact same need - without regular links for attachments for copied images, as shown by @breakson, the structure of saved markdown files is quite weird about embedded images (with [[ ]]) … how can i change this --> in order to have screenshots copied from clipboard named in a regular markdown way ?

Also, is it possible to have images named with a increasing “pattern” (maybe based on the current note name + timestamp) ?

2 Likes

Excuse me, but when I used complete path to embed an image, it can’t display in preview, I don’t know if it is a bug or some other problems?
Hope to see your reply~

Make sure you do these 2 things:

  1. Set the complete path to the image file properly, taking into account the very folder with the attachments. For instance, if you have an ‘ Attachments ’ folder in the root, and your note is located in ‘ Folder-1/Sub-Folder-1 ’, the path should be (../../Attachments/file.jpg)
  2. After doing that, click Ctrl/Cmd+R on your keyboard to “refresh the page”.

Thank you for your reply! I tried the method as you say, but the picture cannot display in preview, it just looks like a broken picture, which usually happen when the internet is bad and pictures on a website failed to load… I don’t know, maybe it is a problem belong to me only… Bad luck :sob:

Could you share a screenshot of what exact line of code for inserting an image you use?
And tell in which folder the given attachment (image) is stored in your Obsidian vault?

Thank you for your reply! I have uploaded the screenshot. Hope that works~

OK, the screenshot is helpful.
You’ve set the system Windows-specific path, which is not needed in this case.

You just need to use ![3](/Attachment/3.jpg). Then - just to make sure all was picked up by refreshing Obsidian with Ctrl+R.

And also, set this feature from the dropdown in Obsidian settings:

Thank you so much for helping me, but I tried as you told me, and the image disappeared in preview… Sorry to disturb you so many times :frowning:

This should work, in fact:
image

Please try to refresh the app by Ctrl+R. Also, you may try
![](Attachment/3.jpg)

I think I know your problem. Where is your note “Embedding images” ? You have to go up to the root location, then you can use the syntax breakson recommended for you.
For example: (use “…/” to go up the file system)
image

Also: set this to “Relative path to file”

I’m new to Obsidian, and am confused about including images. (I’m on Mac Catalina).

Have a large number of existing .md files, with Markdown image syntax, where the path to the image is the full system path, not just the path within the vault.

This full path is recognizable and used by several Markdown editors, but it doesn’t work in Obsidian.

Is this feature of referring to images outside the vault not yet implemented, or is there something that I may have missed to make it work?

TIA