Readwise Integration Backlinking Glitch (or Mistake!)

What I’m trying to do

Create the Author and Category field properties as backlinks when importing from Readwise.

Things I have tried

In the YAML section of the customize Readwise screen:
:teacher:t2:author: [[{{author}}]]
:radio:type: [[{{category|replace(“books”,“:blue_book: Book”)|replace(“articles”,“:newspaper: Article or Video”)|replace(“tweets”,“:bird: Tweet”)|replace(“podcasts”,“:studio_microphone: Podcast”)}}]]

What shows up in my vault (example below, but it happens for every single import) is this in source mode:
- - Lloyd Alexander
- - 📘 Book↙️

And this in live preview:
:teacher:t2:author: [[“Lloyd Alexander”]]
:radio:type: [[“:blue_book: Book”]]

And in live preview mode the next is orange… not sure if that means anything significant.

Really appreciate any insight y’all might have! Thank you!!!

1 Like

I’m seeing the same thing. It looks like a parse error in that I can’t use ‘[[’ ahd ‘]]’ in YAML, or else the type of author doesn’t resolve correctly, and the string adds quotes to the author name.

I’ve tried escaping the brackets with [ but that doesn’t work either, nor does quoting each pair of brackets or the whole string “[[{{author}}]]”.

So, no answers here, but I’m bumping this question with a “me too”.

1 Like

I’m also seeing the same issue and haven’t been able to find a solution.
In Readwise, I enter the following in the YAML front matter

Title: {{title}}
FullTitle: {{full_title}}
Author: [[{{author}}]]
URL: {{url}}
Category: {{category}}
Image: {{image_url}}
Date: {{date}}
Time: {{time}}
LastHighlighted: {{last_highlighted_date}}
Published: {{published_date}}
Summary: {{summary}}
Source: {{source}}
Service: [[Readwise]]

And this is what I’m seeing on the Obsidian import / sync…

I believe I have the solution (courtesy of the Discord forum). This worked for me.

[] denotes a list in YAML, try wrapping it in quotes so it doesn’t think it’s a list
Author: “[[{author}]]”

This makes sense for my previous example because the properties type is set to text so entering what it believes is a list caused the property icon to show the ‘?’ and the orange text.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.