Re-adding words to Language Integration tool suggestions

By mistake, when correcting my typos in a section of text I added ‘dont’ (without any apostrophe) to my dictionary. Obviously, this was a mistake as I should have clicked on the suggestion of ‘don’t’. Now, even though I have removed ‘dont’ from the custom dictionary file in both my Mac and PC synced versions of Obsidian, AND uninstalled/reinstalled the plugin, I am still not getting any suggestions offered to correct the word ‘dont’ to ‘don’t’. A workaround is to go back to using the autocheck which shows the bubble pop ups but tbh I’m much more comfortable right clicking then using the bubble pop ups.

Any suggestions for how to reinstate suggestions for a word spelling correction are welcome!

Here are two screenshots showing my problem - (a) dont, with no suggestions, and (b) isnt with correction suggestion

Screen Shot 2023-12-28 at 15.55.05

Screen Shot 2023-12-28 at 15.55.25

I’m not familiar with how the plugin works. I am just using the built-in Spellchecker.

It’s possible that you need to remove the mistakenly added bad-word from Obsidian’s built-in custom dictionary as well?
Head to Settings > Editor > Behavior and click the icon next to the label Spellcheck (if it’s on at all) and check the word in the list.

thanks for reply. Yes Id done that (both synced machines), although I didnt know you could access that list via settings so was doing it ‘manually’. It’s odd that it still doesnt read as a typo.

As I said I’m not familiar with what benefits the third party plugin gives. What happens if you disable it? Does the plugin utilize a data.json file in the plugin folder that you can inspect? Etc.

I think the main purpose of the Language integration is for multi-lingual functionality but it also provides a nice pop up of spelling corrections or comma adding etc. Interestingly, ‘dont’ now recognises as an error and a correction of ‘don’t’ is offered via the plugin, but is still not recognised with the standard spell check - no error is underlined and therefore no suggestions are provided via right click. I’ve also deleted all temp files, and made sure that the mac synced with this vault isn’t conflicting with its own list (NB, thy run separate spellcheck lists). So, I still haven’t managed to restore this word as an error.