Raspberry Pi Installation

I have a Raspberry Pi 4. I have confirmed that it is running a 64-bit kernel by typing “uname -m” which provides output as “aarch64”.

I downloaded the AppImage file, and set execution privileges to everyone. When I double-click the file after, nothing happens. If I try to type “./Obsidian-0.12.15-arm64.AppImage”, I get the error that no such file or directory exists.

Any suggestions?

I got Obsidian installed on my Pi using flatpak.

That hasn’t worked for me either. I followed the flatpak install instructions from here.

I then run:
flatpak install flathub md.obsidian.Obsidian

That gives me this output:

Looking for matches\u2026
error: Nothing matches md.obsidian.Obsidian in remote flathub

Any suggestions?

The only difference between the instructions you linked and what my personal installer script does is that I used the --user flag.

sudo apt install flatpak
flatpak remote-add --user --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install --user flathub md.obsidian.Obsidian

I’ve got Kali Linux on my Pi, but other folks have reported success with Ubuntu, Manjaro, etc.

Looking through the forums, it looks like other folks have had problems with Raspberry Pi OS, though that’s not universal.

For the AppImage, did you make it executable (chmod +x Obsidian-0.12.15-arm64.AppImage) before trying to run it?

Just tried adding the --user flag but it still can’t locate Obsidian on the third step.

For the AppImage, yes, I tried the chmod command as you suggested. When I then try to execute the file from the command line, I get the “No such file or directory” error.

So, I just took some time over lunch to try to reproduce your problem, and can’t. Here’s what I did:

  1. Burned the latest version of Raspberry Pi OS ARM64 to a USB thumb drive.

  2. Booted and stepped through the normal first-run experience (set timezone / keyboard / wireless network, installed updates, rebooted).

  3. Installed Flatpak and Obsidian.

    sudo apt install flatpak
    flatpak remote-add --user --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
    # Rebooted here, just to be sure
    flatpak install --user flathub md.obsidian.Obsidian
    flatpak run md.obsidian.Obsidian
    # Note that the Flathub version is out-of-date, but will
    # auto-update to the most recent version the first time it's run.
  4. For good measure, tried to download and run the most recent AppImage.

    curl -L -O https://github.com/obsidianmd/obsidian-releases/releases/download/v0.12.15/Obsidian-0.12.15-arm64.AppImage
    chmod +x Obsidian-0.12.15-arm64.AppImage

In both cases Obsidian ran without issue for me (though FWIW the current 64-bit build of Raspberry Pi OS would hang on me every other boot).

You might try removing and re-adding the Flatpak repos (both user and system), but given that you’re also having trouble with the AppImage I suspect that won’t help. If I was in your shoes i might try burning a new Raspberry Pi thumb drive / SSD / microSD / whatever you’re using and then give it another go, as at this point I’d be suspecting that something was wrong with the underlying OS.

Sorry I can’t help more.

1 Like

Following this with interest. One day we’ll carry a RasPi 400 and an HDMI cable around and plug into the next best TV … :wink:

I’ll try installing Raspbian from scratch using the image. What I did before was use the 32-bit image, and then update the kernel to 64-bit. Is there a reason that wouldn’t work, to your knowledge?

Oh yeah, I’d expect there to be problems with that approach, since I’ll bet all of the associated libraries are still 32-bit (it’s not just the kernel that needs to be 64-bit — you need the whole OS stack to support it).

I’ll bet you dollars to donuts that if you reinstall using a pure 64-bit image that you’ll have much better luck.

Thanks for the help - that seemed to have done the trick. Downloaded the AppImage version, used chmod, and successfully launched. :slight_smile:

Do you know if all Arm versions of the app have an updater included?

I use the Flatpak version, and that one will definitely update. I don’t know about the AppImage version, but I would assume it would as well.

Yep, I see the option is there as well. :slight_smile:

Thanks again!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.