Quote Extends Past Quote Markup

When entering text as a quote, the line following the quote without the “>” symbol is still styled as quote text and treated as a quote by Obsidian. In order to get “normal” text after a quote, it requires two line breaks instead of one.

Steps to reproduce

Type something as a quote.
Hit return
Text following the return does not have the quote character, but is still treated as a quote.

Expected result

Text on a line following a quote that does not have the “>” character should not be treated as a quote.

Actual result

Text on the lines following a quote is treated as a quote until two line returns are entered.

Environment

  • Operating system: Mac OS
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.13.30
    Installer version: v0.13.23
    Operating system: Darwin Kernel Version 21.3.0: Wed Jan 5 21:37:58 PST 2022; root:xnu-8019.80.24~20/RELEASE_ARM64_T6000 21.3.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: off
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 2
    Safe mode: off
    Plugins installed: 10
    Plugins enabled: 0

RECOMMENDATIONS:
Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.


Additional information

Here is a screenshot showing the issue:

Users need to press enter on an empty line to exit block quotes:

Installers need to be updated:

Download from:

Angel

yes you need to have a blank line. It’s part of the spec.

Awesome–I’ll install the new version. Thanks!

1 Like

In the latest version of Obsidian, it still requires two blank lines after a quote to format properly. If there is only one blank line, text is not formatted correctly. If I understand the spec correctly this seems to be a bug? Or are two blank lines explicitly required after a quote?

Show me this happening in the help vault.

The format is

> Quote
> Still quote
Still quote

Not quote.

Here’s an example: Dropbox - 202203014 Obsidian Quotes.mov - Simplify your life

Maybe I’m missing something obvious, but I would expect two returns to exit the quote. Instead Obsidian seems to exit the quote (there is no more ident) but it still styles the text as a quote until there are three returns.

Once again, the spec requires a blank line between a quote and a non quote. You screenshot shows that with a blank line you achive separation. I don’t see a bug here.

There is another scheduled change to the way return acts in quotes in 0.14, but the spec remains: you need a blank line to terminate a quotation.

Right, but shouldn’t it only require two returns to get a blank line after a quote and not three? In this case Obsidian doesn’t seem to recognize the first blank line after a quote and instead requires two blank lines.