QuickAdd Macro Throws "No commands in the selected macro..."

I created a simple macro in QuickAdd using the QuickAdd config interface.
Then I added the macro to the command list in QuickAdd. It was easy since it was the only macro, so there was only one choice, which I selected by left-clicking. There’s no “Okay” button, so I closed the selection dialog and returned to Obsidian to use the macro.

When I run it from Obsidian commands (ctl-p), I get this notification: “No commands in the selected macro. Did you select a macro…?” Yes. Yes, I did select a macro. But to be sure, I repeated this workflow several times.

I deleted and recreated the macro.
I added a couple of simple macros so I had more than one choice.
No matter what macro I select, I still get the same message.

I have to be missing something obvious, right? I’ve watched a couple of YouTubers demo QuickAdd and I’m doing the same things they are.

We shouldn’t underestimate my ability to overlook the obvious, however.

Any ideas?


Restarting the app solved the issue.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.