Quick switcher has stopped open files on pressing enter

What I’m trying to do

On using the quick switcher (Cmd+O), I’m able to search through my vault for my files, but the moment i try to navigate to it, by clicking or pressing enter, it doesn’t open/navigate to the file on the editor. (This used to work a while back - I’ve lost track of when it stopped working though).
On pressing enter, it just closes the switcher, without navigating to the file

Edit: I can confirm that only enter doesn’t work. Cmd+enter works (which open the file in a new tab), as long as you don’t hover the mouse pointer over the quick switcher ui. If you do, cmd+enter also stops working.

Things I have tried

I’ve upgraded to the latest version of the app and the plugins I have (which isnt a lot).
I’ve tried to identity if it is some plugin that is hindering this, but havent been able to identify the culprit (if any).
I’ve gone through this help section, but to no avail

Version 1.4.16 (Installer 1.4.16)
System: Apple M1 Pro | MacOs Ventura 13.5.2

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.