Query Control plugin no longer works in v0.15.0 (and backlinks also don't work when Query Control plugin is enabled in v0.15.0)

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

When running v0.15.0
When Query Control plugin is enabled:

  • queries and backlink no longer work. Only first query result seems to show up in queries and in the backlinks pane

Expected result

Actual result


MacOS Monterey Version 12.4
  • Operating system:
  • Debug info:
    Obsidian version: v0.15.0
    Installer version: v0.14.15
    Operating system: Darwin Kernel Version 21.5.0: Tue Apr 26 21:08:22 PDT 2022; root:xnu-8020.121.3~4/RELEASE_X86_64 21.5.0
    Login status: logged in
    Catalyst license: insider
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Minimal
    Snippets enabled: 1
    Safe mode: off
    Plugins installed: 82
    Plugins enabled: 73
    1: Dataview
    2: Natural Language Dates
    3: Note Refactor
    4: Todoist Plugin
    5: Templater
    6: QuickAdd
    7: Media Extended
    8: Readwise Official
    9: Tag Wrangler
    10: Kanban
    11: Advanced Tables
    12: Copy Block Link
    13: Recent Files
    14: Pandoc Plugin
    15: Show Current File Path
    16: Folder Note Core
    17: AidenLx’s Folder Note
    18: Longform
    19: MarginNote Companion
    20: Emoji Toolbar
    21: Advanced new file
    22: Reminder
    23: Admonition
    24: txt as md
    25: MetaEdit
    26: Find unlinked files and unresolved links
    27: Simple Embeds
    28: Tasks
    29: Excalidraw
    30: Periodic Notes
    31: Tracker
    32: Completed Task Display
    33: Icon Folder
    34: RSS Reader
    35: Supercharged Links
    36: Quick Explorer
    37: Buttons
    38: Better PDF Plugin
    39: PDF Highlights
    40: Search on Internet
    41: Map View
    42: Remember cursor position
    43: Calendar
    44: Day Planner
    45: Fullscreen mode plugin
    46: Number Headings
    47: Todoist Text
    48: AidenLx’s Folder Note - folderv component
    49: Spaced Repetition
    50: Obsidian42 - BRAT
    51: tq
    52: Minimal Theme Settings
    53: Contextual Typography
    54: Style Settings
    55: Hider
    56: Customizable Page Header and Title Bar
    57: Obsidian42 - Jump-to-Date
    58: Obsidian42 - Text Transporter
    59: Auto Note Mover
    60: Dynamic Embed
    61: Advanced Mobile Toolbar
    62: Custom Frames
    63: Todoist Link
    64: obsidian markmind
    65: Omnisearch
    66: ExcaliBrain
    67: Typewriter Scroll
    68: Notion-Like Tables
    69: Multi-Column Markdown
    70: DB Folder
    71: Hover Editor
    72: Annotator
    73: Pluck

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

We don’t take bug reports involving plugins. There have been API and architectural changes. You need to contact them, and if there is a problem they contact us.

I have created an issue on the author’s github.
But Im not sure how long will it take the author to notice this issue and to fix it.

And currently, I have returned to 0.14.15. This plug-in is very convenient for me to read and check the dynamic todo list. I can get all the necessary information without leaving the note or opening the other notes.

1 Like

You’re not the only one with this problem, @GLight. I’m also hoping for a speedy fix.

I had a look at of the src cloned from the github, it uses an old version of API. And it looks like that the API of Obsidian v0.15 is very different from the one that is used by this plugin. Even knowing what’s going on in the API beyonds the scope of my knowledge.

I think I have to give up fixing this by myself. It is just too complicate for me. :sweat_smile:

1 Like

The author provided the update.
Now query-control 0.4.0 works fine with Obsidian 0.15.2.

:smiley: we can move to the 0.15.x era.

BTW, you can find the author here:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.