Publish with embedded Excalidraw drawing

I want to Publish a note that has an embedded Excalidraw drawing in it. Instead of seeing the drawing, I get the following message in the published note: “:warning: Switch to EXCALIDRAW VIEW in the MORE OPTIONS menu of this document. :warning:”. I can’t find that setting and don’t know how to proceed. I can save the note as PDF and the drawing is visible, so I assume that this is operator error of some kind of mine, but, I need more excruciating details…

Hi @guitarvydas,

I’m not an expert on Obsidian Publish, but I have seen this behavior in other areas of Obsidian (e.g. with embedding Excalidraw drawings into slides).

The trick I use is to export the Excalidraw drawing to a PNG image, then embed the PNG image in the note instead of the Excalidraw drawing. To make this less tedious, Excalidraw has settings that will automatically create a PNG file for your drawing and update it as the drawing changes.

I hope this helps!


Here are the Excalidraw settings for auto-export and update:

Thanks for the detailed reply!

I confirmed that this was also happening in the core plugin Slides. Applied your fix and now my slides seem to be OK and showing Excalidraw images.

But, this doesn’t seem to have changed the Published note. I still get the warning and no images. I made sure to publish linked notes, too.

I’m getting closer, but something still seems to be off…

You’re welcome, glad slides are working for you now!

I don’t use Publish myself, so I hope someone is able to help you with the last mile there.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.