Publish: Published PDF blocked by server on Mobile

Steps to reproduce

Publish a PDF using Obsidian Publish.

Expected result

View the PDF at on desktop and mobile.

Actual result

Works fine on desktop and used to work fine on mobile too. But in the last 2 weeks or so, every published PDF shows “blocked by server” on mobile. (Markdown notes are fine.)


  • Operating system: Chrome on Android

  • Obsidian version: 0.12.12

Additional information

I’ve tried this on various phones (all Chrome on Android) and various networks.

My published vault is password protected.


Hi again. This seems to have worsened? Published PDFs now no longer appear on Chrome desktop or mobile, even in the sidebar. I can see that they’re published okay from Obsidian. It’s just that they’re now not even evident in the web browser.

I don’t think pdfs ever showed on the sidebar.
Can you post some screen recordings of this?

It works fine for me on Desktop.

Thanks WhiteNoise,

Maybe you’re right about published PDFs never did show in the sidebar (and if that’s the intended behaviour then that’s fine). But here are screenshots of my problem.

First, my note, which contains two links to PDFs within the vault:

The note and both PDFs are published.

The published PDFs don’t appear in the published sidebar. But clicking on one of the PDF links in the published note renders fine in Chrome desktop:

But the exact same in Chrome mobile on Android doesn’t render the PDF:

I’ve tried this on three different Android phones across two different networks, all with the same result. I’ve tried clearing browsing data too. It used to work, over a month ago now.

I’m in Scotland, UK, if that has any baring on the server.

ok, I can reproduce the problem on chrome mobile.

Thanks :slight_smile:

Same issue for me. Is there a plan to address this?
Is there a workaround? I’d probably be happy if users could download the pdf, although displaying it would of course be even better.
Thanks, jb

I am also having this issue. Tried with Chrome, Samsung Internet, and Firefox on both a Samsung Galaxy S21 Ultra and a Samsung Galaxy Tab 7+. None of them embed the PDF in the page properly, although as soon as the page is loaded in Firefox, a prompt appears asking if the user wants to download the PDF.

I would greatly appreciate if this was fixed.
In the meantime, does anyone have a workaround to display the PDF embedded in the page on mobile browsers without an explicit download?

Are there plans to allow publishing pdf’s in the future? Thanks.

I will try what I can later, it might be a new browser restriction, but maybe it’s something we can work around with some tweaks

I am still struggling with this- PDFs don’t work on Obsidian publish websites when viewed on a mobile device. I’ve tried various browsers on Android.

Also having trouble viewing PDF I published to Obsidian Phblish (iPad).

Any news on fixing this?

The handling of pdfs is being reworked. When the new system will be deployed this bug will be fixed. There are no ETAs

I’ve done another round of investigation here and it seems to be a bug with Chrome on Android - the embedding works fine on iOS, and other browsers on Android like Firefox.

Unfortunately I’ve tried all I can to make Chrome render it, but sadly it always refused to do so. The only way to fix this moving forward would be to use a custom PDF viewer, or open the PDF for download.