Publish not seeing publish.css

Hi all,

I’ve finally knuckled down and got Publish. I’m feeling particularly silly at the moment as I cannot get Obsidian to see my publish.css file. I’ve taken the CSS of a particular theme and put it in the root folder of my vault. (See the picture).


No matter what I try, I cannot get Publish to pick it up.

I’ve followed the instructions here: Customize your site - Obsidian Help and here: How to apply custom css snippets to Obsidian Publish? but no joy.

Did I mistake the rootfolder? Or am I just missing something super simple here. (or alternatively, I may just be really thick.)

Thanks for any help :slight_smile:

1 Like

I am having the same problem with my site. Please advise, Obsidian.

(Also, a request for proper support contact information for those of us paying you money for a product.)

I’m sorry to ask the obvious. Did you check at the right place ?
Once you have invoked the “Publish Changes…” command, if the “publish.css” is not yet published, it will appear in the “New” section and it is not necessarily selected.

Maybe you could check this ?

I had the same problem and fixed it by:

  1. deleted the publish.css fil & added it again
  2. “reload app without saving” via command command palette

Then it should show up in the new section when publishing changes :')

Hi Oliver. I did check at the right place, the ‘new’ section. But no joy. Thanks for taking the time to reply though :slight_smile:

Tried that too, no joy. I’m feeling a little foolish here. Surely it shouldn’t be this complicated? I feel like I’m missing something!

Is it possible you’ve published publish.css before, and it’s appearing in “Unchanged” or “Changed” instead of new?

Expand each section of the Publish modal, then filter by publish.css. Take a screenshot of that, then share it here.

Hi Ryan,

Thanks for the mail and reply on here. Done so, even republished everything including the CSS and it’s still not showing up.

Screenshot as requested:

Any help is appreciated :slight_smile:

Okay, further investigation: can you enable all filetypes and locate publish.css in the file explorer?

Alright, done that. Good news (providing my location for the publish.css as per the screenshot above was correct to begin with), I can now see it in the list to the left but I still cannot see it ready for publishing. I tried filtering to it as well btw, but the result is the same.


Hmm it looks like this for me:

Any chance you named it “publish.css.css”? (On windows, the OS by default “hides” the file extension)

1 Like

I knew it was bound to be something stupid. >.< Thank you. I had completely forgotten Windows by default hides file extensions.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.