Publish: Mouse stuck in Graph view not working in Firefox

Steps to reproduce

Open any Obsidian publish site in Firefox (tested it on the official documentation)
Click on the graph view. It will now be stuck to your mouse.

Expected result

You would navigate to the node you clicked.

Actual result

Node gets stuck to mouse and no other nodes can be clicked.


  • Operating system: Windows 10 b19042
  • Obsidian version: 0.12.15 (but irrelevant since it’s publish related)

Additional information

Stack trace of the error I get in the console.

Uncaught ReferenceError: TouchEvent is not defined

I tested it on Chrome, it worked there.
Have also tried using incognito mode and disabling anti tracker protection and adblock in Firefox.

What appears to happen is that TouchEvent is not defined on Firefox if there’s no Touch available, so either polyfilling TouchEvent would work in such a case, or switching to PointerEvent or simply checking for TouchEvent being undefined.

PointerEvent also seems to have a wider browser supoort, but I don’t know if the specific functionality of TouchEvent is needed or not.

Have same issue using Safari (v14.1.1) on Mac Big Sur. Issue only just started in last few days (node getting stuck to mouse). Problem does not occur in Chrome.


This should be fixed now. Try to force reload the page.

Yes, it is fixed now.

Thanks :blush:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.