Publish keeps throwing "File hash mismatch" error

Steps to Reproduce

  1. Open Obsidian (version 1.4.14) on a Windows 10 Pro system.
  2. Navigate to the vault containing the problematic file.
  3. Make edits to the file.
  4. Attempt to publish the file via Obsidian Publish.
  5. Observe the error message.

Did you follow the troubleshooting guide? [Y/N]

  • Ensure you have followed the guide and the issue persists in a sandbox or restricted environment.

Expected Result

After editing the file and attempting to publish it, the file should be successfully published without any errors.

Actual Result

An error message is displayed every time an attempt is made to publish the edited file.



  • Obsidian version: v1.4.14
  • Installer version: v1.4.5
  • Operating system: Windows 10 Pro 10.0.19045
  • Login status: logged in
  • Catalyst license: none
  • Insider build toggle: off
  • Live preview: on
  • Legacy editor: off
  • Base theme: adapt to system
  • Community theme: none
  • Snippets enabled: 0
  • Restricted mode: off
  • Plugins installed: 6
  • Plugins enabled: 4
    • Templater v1.16.0
    • Map View v4.0.0
    • Dataview v0.5.56
    • Update time on edit v2.4.0

This is the original content I uploaded successfully through the Publish ribbon button:

This is the updated content:

And this is the error in the Publish modal:

Here is the error message in the console:

Please help! I love the feature this is my first time using it and I’m thrilled at the potential, but this is a feature-breaking bug for me. I cannot update my pages, and that will cause me to cancel my subscription.

thanks, we’ll look into it.

Thank you! I appreciate your app so much it’s my absolute favorite. It’s been a complete game-changer.

Delete the file first, upload the deletion and try again
Can you post or DM me a copy of the raw original file?

Problem not solved on 1.4.16

Delete the file first, upload the deletion and try again
Can you post or DM me a copy of the raw original file?

Problem : The file is not published (since yesterday) so I can’t delete it…

:minidisc:|attachment (1.3 MB)

Is-it possible to delete completely a website and recreate one without paying ? I’am in this situation now…

It seems the problem come from a plugin which ad date to property created and updated.

Wasn’t that… To avoid the bug I open the file with sublime text, modify it, save it… And it works.

I am not sure I understand you. I am very confused.

Let begin from zero. Enable restricted mode, restart obsidian, try to upload the note.

Does it work?

Enable restricted mode, restart obsidian, try to upload the note.

No it doesn’t work if I want to send a file I need to open it and save it with another editor…

With Enabled restricted mode

Before :

Changing it and saving it with sublime text:

Now it works :

The issue is with the “Update time on edit” plugin. I love this plugin, but it doesn’t work with Obsidian publish. I created a folder and then made new notes in it for testing. You need to exclude this folder in the plugin settings. Only then will it update correctly with Obsidian publish.

I hope this helps!


Hi there, I’m getting the file hash mismatch error. I’ve just set up a new Publish account and a lot of my files won’t upload.

I’ve tried disabling the plugins, but that didn’t work.
I’ve got lots of files that won’t upload, so I don’t want to go through them all one-by-one to rename them.
If anyone knows how to fix this, I’d be glad to hear from you.

Were you using the “Update time on edit” plugin?
Enable restricted mode, restart obsidian. Does it still happen?
If it still happens attach here or DM me a link to one of the note that doesn’t work

Hi, I’ve switched off “update time on edit” and I’ve enabled restricted mode and restarted Obsidian, but I’m still getting the same error message on many of the files.

Here is one of the files that won’t upload to Publish

RT-P1 - The Red Tetrahedron, Portal (6.0 KB)

Thank you for looking into this.

what happens if you unpublish and republish that note (always with restricted mode on)

I’ve tried re-uploading the whole vault with restricted mode on, but I’m still getting the same result: ie there are still a lot of files that give me the file mismatch error.

Do you still have this problem?

I still have this problem I use the “Update time on edit” plugin as well. I’ve tried any number of - unpublish/publish, restart obsidian, and restricted mode on. Without going into the plugin’s code deeply, it seems some store that Obsidian uses must be getting changed by this plugin. Then again, I’ve never developed a plugin, so I’m not sure what’s going on here in the background. However, I know it’s not some edge case that occurs during the Publish sequence because I have the plugin turned off with Restricted Mode.

update-time-on-edit-obsidian/src at main · beaussan/update-time-on-edit-obsidian

did you restart obsidian after disabling the plugin?