Properties remain visible after Disabling the new "Properties" feature in Settings > Core Plugins

Steps to reproduce

1 - Navigate to Settings > Core Plugins
2 - Disable the “Properties” plugin

Did you follow the troubleshooting guide? [Y/N]

Yes

Expected result

  • The new properties section is hidden (disabled) on files in the editor in Live Preview Mode.
  • The new properties section is hidden (disabled) on files in the editor in Read Mode.
  • Frontmatter is displayed as it used to before version 1.4

Actual result

  • The new properties section is visible (enabled) on files in the editor in Live Preview Mode even when the plugin is disabled
  • The new properties section is visible (enabled) on files in the editor in Read Mode even when the plugin is disabled

Environment

SYSTEM INFO:
Obsidian version: v1.4.1
Installer version: v1.3.5
Operating system: Windows 10 Home 10.0.22621
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 0
Plugins enabled: 0

RECOMMENDATIONS:
none


Additional information

Right now, this is intentional. The properties core plugin manages the sidebar tabs not the properties in the editor. You can open a feature request about this.

Also, it would be helpful to have feedback on what is stopping you from using the new ui.

@renatomen Would this setting do the trick for you? Settings -> Editor -> Show file properties

In my case, it keeps converting the deprecated cssclass: to cssclasses: which breaks the Tufte-sidenotes CSS from the Cornell Notes system.

Could you set it up so toggling Properties off would actually stop it from fooling with the YAML?

The solution seems to have been posted in a different thread yesterday Turn off new YAML 1.4? - #24 by mycoJuan

Settings> “Editor” tab> “Display” heading > “Properties in document” > “Source” option.

1 Like