Properties prevents editing frontmatter like a text file

Before opening a new bug report, please search the forum for duplicates and follow the Troubleshooting Guide.

  • We only consider bugs that are reproducible in the sandbox vault or a vault with no third-party plugins/no css snippets/default theme.
  • For Linux, we only accept bug reports that are reproducible with our Appimage package under Gnome or KDE.
  • Developer issues with the API should go here

Once you’ve done the above, delete everything above this line.

Steps to reproduce

Put a character in front of the “—” to block properties from treating it like something special, say “x—”. Now, try to delete the ‘x’. There does not seem to be a way to make Obsidian go back to the previous behavior of treating frontmatter previous to 1.4 release. Even in source view, the frontmatter gets special treatment. I have to open files with vscode to fix them so Obsidian works correctly.

Did you follow the troubleshooting guide? [Y/N]

Expected result

I tested in a restricted vault and it has the same behavior. You can’t “convert” or “promote” plain text to a frontmatter block anymore.

That Obsidian would delete the ‘x’ and convert the text to frontmatter.

Actual result

You cannot delete the x character, the line stops behaving like a text file becomes some weird locked thing.


Obsidian version: v1.4.5
Installer version: v1.3.4
Operating system: Windows 10 Home 10.0.19045
Login status: logged in
Catalyst license: supporter
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 1
Restricted mode: off
Plugins installed: 23
Plugins enabled: 23
1: Calendar v1.5.10
2: Dataview v0.5.56
3: Natural Language Dates v0.6.1
4: Obsidian Charts v3.7.2
5: Periodic Notes v0.0.17
6: Advanced Tables v0.19.1
7: Regex Find/Replace v1.2.0
8: Better Word Count v0.10.0
9: Templater v1.16.0
10: Heatmap Calendar v0.6.0
11: Text Generator v0.3.20
12: Text Progress Bar v0.2.0
13: Pandoc Plugin v0.4.1
14: Obsidian Ghost Publish v1.3.0
15: Numerals v1.2.0
16: Readwise Official v2.0.1
17: Tidy Footnotes v0.1.1
18: Typewriter Scroll v0.2.2
19: ChatGPT MD v1.5.0
20: LanguageTool Integration v0.3.4
21: Style Settings v1.0.7
22: Excalidraw v1.9.19
23: MetaEdit v1.8.2

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

can’t reproduce in 1.4.8

That’s good to know. 1.4.5 is the official release, so I guess I have to wait until 1.4.8 is out.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.