Properties keep coming up invalid on Desktop and iPad whenever I sync via Git and turn on one or the other

What I’m trying to do

I have several properties that I sync between my iPad and Desktop via Working Copy on iPad (and iPhone) and Obsidian Git on Windows.

I notice that when I fix the errors and then sync my vault via one of the solutions and then go to open the same vault on another device the properties come up with the “incorrect data” error.

I can’t file a bug report cause I cannot recreate this on my test vault (yet). My test vault has a few properties (a few checkboxes just like this) and I have synced it to git via Working Copy. I am not home to set it up on my desktop though to test that part. When I get home I will test that and either edit this post or add a comment.

Things I have tried

Every. Single. Time. I open the files (this happens on several files) I. Always. resolve the errors. Then it is fine as long as I keep using Obsidian on that one device.

As soon as I close sync Obsidian to use the other device, it happens.

I have attempted to use Working Copy on both my iPhone and iPad and sync my test vault to both but the error doesn’t recur on my test vault. No plugins, no themes, just 1 file with lorem ipsum text.

These errors DO recur on my iPhone from my iPad though. I have attempted to change the markdown as you can see below.

I even changed 2 checkboxes (as you can see) that are not having any issues.

These are all of the properties for this file:

I have tried force closing the app and reopening. I have fixed these (since the first screenshot) on my iPhone and as you can see my iPad still shows issues.

Looks like working copy or Obsidian is manipulating those props cause I can see the last commit is where I added the quotes (screenshot above) and now this is what I see currently on my iPad:

This is incredibly strange and I don’t understand what is going on or how to fix it.

Do you have a Frontmatter Modified Time Update (either of the two) plugin enabled on mobile?

I disabled them because one of them kept double-quoting one of my tags.

I don’ have Properties on mobile, yet. Not sure if it’s out for Insiders.

I’d be surprised if syncing had anything to do with it.

No I do not have either of those.

Maybe if you paste a portion of the YAML where you’re seeing the error (as code) - we could test syncing

  - across
  - devices

that might help.

Sorry should have done that…

title: Things 3
dg-publish: true
dg-updated: 2023-09-26T20:35:00
dg-created: 2023-09-14T18:28
dg-path: Task Managers/Things 3
dg-permalink: Things
author: Erin Skidds
  - iOS
  - MacOS
openSource: "false"
worksOffline: "true"
cloudAccess: "false"
multiDeviceSync: "true"
attachmentSupport: false
collaboration: "false"
2FAoptions: "false"
dueDates: "true"
doDates: "true"
hasAnAPI: "false"
pluginSupport: "false"
hq: Stuttgart, Germany
freeOption: "true"
otpOption: "true"
otpPrice: 80
anyDiscounts: "false"
discountURL: []

I just got home and tested my test vault on my PC and syncing it via Obsidian Git and Working Copy (the same way I do my regular vault) does not have any errors.

I don’t understand what in my vault could be causing it. Here is debug info from my main vault:

	Obsidian version: v1.4.14
	Installer version: v1.4.13
	Operating system: Windows 10 Home 10.0.22621
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: on
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: AnuPpuccin v1.4.4
	Snippets enabled: 4
	Restricted mode: off
	Plugins installed: 21
	Plugins enabled: 17
		1: Obsidian Git v2.20.7
		2: Calendar v1.5.10
		3: Dataview v0.5.56
		4: Digital Garden v2.45.2
		5: Editor Syntax Highlight v0.1.3
		6: Highlightr v1.2.2
		7: Settings Search v1.3.8
		8: Tag Wrangler v0.5.11
		9: Tidy Footnotes v0.1.1
		10: Templater v1.16.0
		11: Paste image rename v1.6.1
		12: Emoji Toolbar v0.4.1
		13: Discord Rich Presence v1.5.1
		14: Taskbone v2.0.1
		15: Force note view mode v1.2.0
		16: Wiki Digital Garden v2.45.2
		17: Style Settings v1.0.6

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Definitely not a bug in Obsidian if my test vault isn’t doing it. Must be a plugin or something?

I have all kinds of invalid YAML key fields according to Properties/Obsidian, by the way.
I don’t really take heed because as YAML fields they are valid and Properties don’t alter the raw content of fields themselves.

I am not sure if they are made invalid on vault indexing or at the moment the actual file is opened in Live Preview.

As for git, it’s good to have it for perusing older states of files to ascertain all is A-OK.

Are you talking about with the yaml I shared or with your own vault and information?

It seems like you are rambling off to your own conversation and not providing anything helpful for solving my particular issue?

It is a Forum thread about invalid Properties or being made that way.

As far as I remember, I made sure I directed the reply to the general thread – for other people’s benefit (as well).

I don’t use Working Copy with Obsidian at the moment, but I made a note with the above YAML in two separate vaults (one syncing with iCloud and one with Obsidian Sync). The Properties view on the phone and iPad (Obsidian mobile v1.4.12) of the notes doesn’t show any errors. Changed a few values and watched them sync as well. I doubt syncing is the issue here, but who knows. Good luck!

That is very strange. I wish I could narrow it down. I’m about to turn off 99% of my plugins and go back to a default theme for a few hours to test the syncing and stuff of the YAML.

IF it is a plugin, I wonder which one and why. Super strange.

Thanks for testing for me, I appreciate it!

I have opened a bug thread so I’m going to mark this post as the solution since I have determined that this is indeed a bug as it happens without any plugins or themes or snippets activated on my vault and happens on a brand new test vault with this particular file for me.

I believe it is the sheer size of the frontmatter I have plus the amount of text I have in my file. When I copy the entire file to my test vault (copied and pasted the text (CTRL + SHIFT + V) not the file itself) and sync the error occurs. Very strange.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.