Properties Created via Apple Shortcuts Not Rendering in New UI

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What I’m trying to do

I spent a lot of time with the Tally app today (great app, discovered thanks to Automators’ Rosemary Orchard), and got that set up to track my daily habits. I grab the list (it’s long) with Apple Shortcuts, then replace the 1 and 0 values set my the app with true or false values required by Obsidian. I even got it formatted the way Obsidian wants (“eatHealthy:”: true), but when I prepend it to a periodic note using Actions for Obsidian, and with no spaces before the three dashes of the YAML frontmatter, Obsidian does not display it with the new properties UI. I have properties set up in Obsidian with these names as Booleans. But when I look at the note rendered, it just show text, not the UI. Not sure what I’m missing, or if properties only render when defined from within Obsidian itself.

I want to use Tally rather than Obsidian because I do the logging before bed on an iPhone, and although Obsidian’s mobile app is quite good, all of those properties are very small. But more importantly, I also want to send the Tally data elsewhere for different uses, and want that data to remain numeric.

Things I have tried

I’ve tried editing the note in Obsidian to confirm there’s no space before the YAML. There’s not.

It seems like the eatHealthy has an extra colon in there. That needs to go away.

Could you show us the frontmatter of one of your files, preferably from source mode? You can include it in a forum post using four backticks, ````, before and after the markdiwn you want to include. This would help us identify which issues you’ve got.

If there are errors in the property format the UI won’t render either property, but you can for sure edit the properties/frontmatter outside of Obsidian. It just needs to be correctly formatted.

1 Like

@douglasgottlieb Actions for Obsidian 1.4 introduced File Properties actions, and I think it’d be best to use them instead of prepending raw YAML to your notes.

I don’t know what Tally returns, but Set Note Properties accepts a dictionary (basically a list of key/value pairs) as input, and adds them to your note. Maybe that’s what you’re looking for?

If you need help with that, let me know! :vulcan_salute:t3:

1 Like

Do you have a blank line between the properties block and the body of the note?

1 Like

I rebuilt this from scratch a day later and it all works perfectly now. The issue was between chair and keyboard. Me.

Thanks for looking and chiming in all!!!

I had a bunch of bad things. No space at the top, but after just starting over, it all works fine and as expected. Sometimes just coming back the next day is the best thing. I spent hours banging my head one day, and the following, it all just fell into place the first time. Go figure.

Thanks for chiming in!

Thanks Carlos! I’ll check it out.

I ended up rebuilding this from scratch the following day and it all worked.

But the fearure you mentioned is intriguing. I’ll definitely give it a spin.

Love your app!!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.