Properly show/print arrows

When I type “-” followed by “>” or “=” followed by “>” , it doesn’t properly show the arrow like -> instead it prints two characters separately. I am using clean theme. It will be great if someone can help with proper css settings to modify so that arrows are shown properly.

Thanks!

1 Like

You need to choose a font with ligatures in order to avail of this.

Alternatively, you can save arrow characters → in a text expansion app. Then, you can use them anywhere!

1 Like

I have this:

:root
{
--font-monospace: "Source Code Pro", monospace;
}

at the start of my theme’s code.


I created the Community Theme: Reverie,

In my theme since the font uses ligatures, the arrows are there by default, making this -> into this ->


but I agree with @ryanjamurphy I do prefer using text expansion tools for things like this.


Espanso

I use espanso which is free open source (cross Platform)
espanso - Cross-platform Text Expander written in Rust

My Text Expansion Example

For anyone else who might want to set this up with espanso here’s my set up for arrows.

This is my current set up

I created a file called symbols.yml

in the follwing path

/home/santi/.config/espanso/user/symbols.yml

keep in mind I’m using linux so the exact path will be different, but everything else should be mostly the same.

Make sure to check out Espanso’s Great Instructions
Documentation - espanso - Cross-platform Text Expander written in Rust

Then I have this text expansions in that symbols.yml file:

name: symbols
parent: default
matches:

  # Right
  - trigger: ";right"
    replace: "→"

  # Left
  - trigger: ";left"
    replace: "←"

  # Up
  - trigger: ";up"
    replace: "↑"

  # Down
  - trigger: ";down"
    replace: "↓"

This means that when I write ;down I get this arrow ↓


What I like about this approach (with text expansion) is that now you can use this method anywhere in my computer, not just Obsidian.

Hope that helps @ani and anyone else interested in setting this up

7 Likes