Problem Installing Obsidian in Windows 10 - SOLVED!

Things I have tried

I am having an issue installing Obsidian on my computer at work. Windows 10 on a Network Domain with Webroot for the antivirus.
The log shows the following error codes:

2021-03-19 13:58:09 Loading main app package C:\Users\dave.sugg\AppData\Local\Obsidian\resources\obsidian.asar
2021-03-19 13:58:17 Checking for update using Github
2021-03-19 13:58:17 Failed to check for update using Github (net::ERR_FAILED)
2021-03-19 13:58:17 Checking for update using
2021-03-19 13:58:17 Failed to check for update using (net::ERR_FAILED)

I made sure Obsidian and the Installer were both allowed through the Firewall.
I have uninstalled and reinstalled with the same results.
Any suggestions greatly appreciated.

What I’m trying to do

You can’t install or you can’t update?

It seems to install without any error messages, but when I try to run the program it never fully opens. There is an Obsidian process running in the background, but the program never comes on screen. I am guessing that it gets hung up trying to do the update check and that is why it stalls out. I installed on my home Windows 10 machine with no problems.

I do think your network is blocking obsidian. I do not think that this is what is preventing to start. Maybe webroot is preventing it to start.

I use Obisidian in Windows 10 blocking internet access with Bitdefender firewall and I have no problem. So I can confirm that the internet block doesn’t prevent Obsidian to start. Thr problem is elsewhere.

Found the solution. Our IT Support Company had put in a policy that blocked executables from running out of the user/appdata folder. They had done this to block some ransomware attacks several years ago. Once the policy was changed, Obsidian ran fine.