Problem in moving cursor or trying to select words in last part of note

It happens that an entire block of lines is treated as a single line when moving the cursor.
When trying to select it behaves as a single word.

This seems to happen only at the end of the note.

Moving cursor

  • I move the cursor at the end of the note
  • I try to move it one line up with the keyboard arrow


  • The cursor moves up to the beginning of the paragraph.

I cannot select a single word or group of words of the paragraph, I can only select the whole paragraph.

I tried to go to restricted mode but nothing changes.

I opened the file with a text editor, noticed nothing strange (newlines are OK)

Cursor animation

The last paragraph is the one wth problems.
Se second last which is identical behaves normally.

Selection animation

I’m not able to reproduce this in the Sandbox vault (found in the Help menu on the app’s left edge). Can you try it there?

Also, when you enable Restricted Mode you need to restart the app afterward because some plugins don’t fully clean up after themselves.

I copied my note to the Sandbox, and the problem was not there.
I entered restricted mode in my vault, restarted Obsidian, but the problem was still there.
So the problem should be in the theme and I understood that ITS Theme needed updating.
Updating ITS seems to have solved the problem.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.