Preview mode internal link shows square brackets

For some reason, the internal links are not hiding square brackets in preview mode. Any clue how to resolve this?

Steps to reproduce

Add an internal link using double square brackets and look at preview mode.

Expected result

It should hide square brackets, showing the link as a hyperlink.

Actual result

It shows the link with square brackets.


  • Operating system: Windows 7 64 bit
  • Obsidian version: v0.12.10

post a screenshot of this happening in the help vault.

Totally forgot about this. It does not happen in the help vault. I mean it works fine in the help vault.

ok, so it’s either a theme or a plugin.

1 Like

Community plugins are turned off. I’m using Obsidian Boom theme.

Ah, you are right. It’s the theme - Obsidian Boom. Just changed to another theme and the issue was gone.

Is there a support for Obsidian Boom theme here. Should I create a new post?

contact the author of that theme on github.

1 Like