Plugins stuck loading indefinitely

Steps to reproduce

Be connected to the internet.
Create an obsidian vault.
Add some notes to the vault.
Disable safe mode.
Install a few plugins.
Save everything.
Completely close obsidian.
Connect to a network without internet.
Open obsidian.

Expected result

I would expect obsidian to open, normally. After trying to load the plugins, and being unable to do some networking aspect, with them. I would expect it to timeout or be able to forcibly stop it loading the plugins.

Actual result

The plug-in loading screen displays indefinitely. I’m unable to bypass the screen and do anything on the mobile app. I’m completely unable to switch with vaults I’m using. I can’t get off the plug-in loading screen.

Closing the app, forcibly stopping it, turning off my internet, using mobile data.

I try to reopen the app, and the issue persists.

Environment

  • Operating system:
  • Debug info:

SYSTEM INFO:
Operating system: android 12 (samsung SM-F916U)
Login status: not logged in
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Safe mode: off
Plugins installed: 6
Plugins enabled: 6
1: LanguageTool Integration
2: Natural Language Dates
3: Advanced Tables
4: Dataview
5: Templater
6: Calendar

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.


Additional information

This issue appears intermittently, because it’s an issue that happens, when my Wi-Fi becomes unstable. It’s very difficult to test if it’s an issue with any one of my plugins or an issue with obsidian and how it loads the plugins.

At the very least I believe it’s a missing feature to not be able to forcibly stop the plugins from loading and make me unable to open obsidian until I clear all obsidian app data. After clearing all obsidian app data and in reopening the vault. Even if I am having the network issue. Obsidian opens the first time and prompts me to enter safe mode. I click turn safe mode off. Everything is working. Only after I close obsidian, and reopen it, from this point forward. Do I get the infinite plug-in loading screen.

This is why I believe it’s an issue with obsidian.