Photos disappearing

Photos disappear at random from notes. It just leaves me with a box where the photo once was complaining that the file has not yet been created. Luckily I make backups of my vault and can usually restore the photo, but it’s irritating that I do this manually every so often. If I didn’t make backups, I would be experiencing significant data loss. Is anyone else having this problem? I’ve used Obsidian Sync, EaseUS EverySync, and Synology Drive. None of these synchronization solutions slow down or stop those files from disappearing from my vault.

Can you give a bit more information?

Can you post your “Show Debug Info”?

Where are you storing your vault? Specifically, are you mixing sync/cloud tools? (Including ones that come with your OS, like iCloud or OneDrive.) If you are using multiple syncing tools, that is the likely problem. You will cause race-conditions, and they will overwrite one another.

When does it happen? Immediately after adding a photo? Or does it happen long afterwards? Any additional info you think of?

The sync tools I listed above are all the sync tools I’ve used in isolation. I know the pitfalls of mixing multiple sync/cloud tools together. This is why I would not dare to do such a thing. The photos do not disappear right away. They stay in the main folder in my vault till I rename them, to some title that seems logical to me, then I move them to my ‘_resources’ folder. This is all done from within Obsidian. As far as debug info, not sure what to provide. The photos disappear at random, I have no idea when it actually happens, I just eventually stumble upon a page that has a missing photo. Thus I have to manually go digging into one of my zipped-up backup files to retrieve the missing photo and place it back into my vault. I do appreciate you taking the time to look at my problem and trying to help me figure this out. That goes to anyone else in advance that takes a swing at this.

In Obsidian, run the command, “Show Debug Info”.

SYSTEM INFO:
Obsidian version: v1.3.5
Installer version: v1.1.16
Operating system: Windows 10 Pro 10.0.22621
Login status: logged in
Catalyst license: insider
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Things v2.1.6
Snippets enabled: 3
Restricted mode: off
Plugins installed: 67
Plugins enabled: 47
1: Calendar v1.5.10
2: Periodic Notes v0.0.17
3: Dataview v0.5.56
4: Custom Frames v2.4.6
5: Dynamic Table of Contents v0.0.27
6: Admonition v9.3.3
7: Tasks v4.2.0
8: Dictionary v2.22.0
9: Gallery v0.5.8
10: Collapse All v1.5.3
11: Annotator v0.2.10
12: Homepage v3.3.1
13: Tracker v1.10.9
14: Global Search and Replace v0.3.0
15: Weather Fetcher v0.0.3
16: Shell commands v0.20.0
17: Execute Code v1.8.1
18: Google Calendar v1.9.19
19: Toggle Meta Yaml v1.2.0
20: Yaml Manager v1.3.3
21: Find orphaned files and broken links v1.9.0
22: Plugin Groups v2.1.0
23: RSS Reader v1.2.2
24: Day Planner v0.5.8
25: Excalidraw v1.9.8
26: Text Extractor v0.4.6
27: Icon Shortcodes v0.9.7
28: Tag Wrangler v0.5.11
29: Markdown Table Editor v0.3.1
30: Webpage HTML Export v1.6.0
31: Quote of the Day v1.0.1
32: Journal Review v1.0.2
33: Text Generator v0.3.20
34: TagFolder v0.16.1
35: Style Settings v1.0.6
36: Omnisearch v1.14.2
37: Key Sequence Shortcut v2.0.2
38: Banners v1.3.3
39: Obsidian Query Language v2.1.1
40: Sort & Permute lines v0.7.0
41: Timelines v0.3.2
42: Templater v1.16.0
43: DB Folder v3.4.0
44: Local REST API v1.6.0
45: Dice Roller v9.0.0
46: Meta Bind Plugin v0.5.1
47: Text Snippets v0.1.2

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.