"Permission Denied" on adding/renaming note in Android

Steps to reproduce

Open A new tab.
Tap on Create new file.
Try to rename the file ( the actual title of the file )
I cannot do this.
It says “user denied permission request”

Which is weird because when I use search function to create new file I face no such problem.

( yes I granted the file permissions which obsidian had asked me)

Did you follow the troubleshooting guide? Y

Expected result

Should be able to create new file.

Actual result

Permission denied


Operating system: android 12 (Xiaomi M2007J20CG)
Obsidian version: 1.4.8 (107)
API version: v1.3.7
Login status: not logged in
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

Actual Android version is 13 though

fix it please.

Additional information

1 Like

I’m also not able to create folders or delete files

I am on android 13 and it works me. I think you have some permission problem or maybe it is something specific to your phone

Screen-20230901-044917.zip (1.7 MB)

Here’s a screen recording of it happening.

Could be related to my device though. I’m using a custom rom AOSP 13.

This problens hhappen with me when i reinstalled the obsidian in the app store too

I’ve installed older version 1.4.5 on Android and I’m not facing issue on that.

There must be something wrong with latest release. ( 1.4.8 )

Which phones do you have exactly?

There is an Samsung with android 13, i’ve get this error when i uninstalled and installed again, so after this, i get the same error that this posting forum

1 Like

Installed Obsidian for Android last night, and synced it with my vault.

I can create new files in a folder, but when I try and rename them from “Untitled” I get this error:

Unable to do file operation, user denied permission request

The vault was created on a windows laptop and continues to work fine there, but I’m not sure what to do to allow file renaming when obviously file creation seems to work fine within the vault from Android.

I’m facing the same issue as well.

We are aware of the issue. A fix is being worked on.


How do you installed the older version in android ?

I had to uninstall latest version first.

I found the older version on Apkmirror.

Im facing the same issue, samsung S23+ with Android 13.

I’m having the same issue.

Samsung Galaxy S22
Android 13
Obsidian version 1.4.8

Iam on samsung galaxy A13 android v13 and facing same problem.

On Android 11 I need to confirm with return to rename notes, but in previous versions I hadn’t.
Usually renaming worked just fine without the return button, i liked more the previous behavior

Same problem, Samsung Galaxy S23 Ultra running OneUI 5.1 and Android 13

I’ve found that 1.4.7 (downloaded from the 3rd pinned message on discord in the #insider-mobile-release channel) still seems to work, just 1.4.8 that the problem is introduced.

Will be fixed in mobile version 1.4.9


Hi, same issue here, thanks for the replies and incoming update, is there an ETA for the release of 1.4.9?

Many thanks, amazing community!