Peculiarities of vim: tilde and @ not working as vim commands but as inserting before cursor, even if in command mode

when in command mode (on my swiss keyboard) one can normally use tilde to switch case and @ to execute macros.
in obsidian however, the following happens for me:
@: before: “asdfasdf” after: “[email protected]
tilde: before: “asdfasdf” after: “asdfasdf~”

I checked my hotkeys in obsidian for some interference but nothing.

Recording: https://imgur.com/R9BpA7R

Do others have that problem as well or is that something with my setup?

Please resubmit this bug report and make sure that: 1) you follow the bug report template, 2) you use the default theme (no css) and 3) there are no third-party plugins enabled (You can use the help vault for 2 and 3).

Side note: They both work for me.

fixed the error. this can be deleted.

will follow the bug structure in the future. thank you @WhiteNoise