PDF viewer not working iOS

Steps to reproduce

Have a pdf file within a file, but also showing up in the file explorer
Sync the vault to ios
Turn on syncing for pdf’s specifically for both devices
Restarted both devices and apps

Did you follow the troubleshooting guide? [Y]

Expected result

To be able to view the PDF within the IOS Obsidian app

Actual result

The app shows the PDF viewer with the correct title, except the PDF viewer in the app is empty

The file seems to have synced: as it is showing in the phone’s file app, within the Obsidian folder, but when I click on it from the file app, it takes me to the Obsidian app and shows the same empty PDF viewer, displaying 0 of 0 pages.

I restarted both devices, restarted the apps, and re-installed the iOS app. The apps are fresh installs in restricted mode and default themes and were when the sync was made.

Opening up synced Word documents through the ios Word app works, it’s just the PDF that doesn’t

Tried with one other PDF file, same result. My PDF file is 1.28MB


Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: Windows 10 Home 10.0.19045
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

Operating system: ios 15.0 (Apple iPhone)
Obsidian version: 1.4.16 (114)
API version: v1.4.16
Login status: logged in
Catalyst license: none
Vault ID: 68ee9261258aa0810c5de0faf6268c28
Host server: wss://sync-12.obsidian.md
Device name:
Allowed file types: image, pdf, unsupported, video, audio
Allowed special types: app, appearance, core-plugin, core-plugin-data
Ignored directories:
Prevent sleep: false

Additional information

See above ‘Actual result’

Update iOS.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.