PDF file drag and drop not completing in 0.14.3

I am unable to drag and drop pdf files into open Obsidian documents in Mac OS 12.2.1. using Obsidian 0.14.3

Steps to reproduce

  1. Start Obsidian
  2. Open a markdown document
  3. Switch to editing mode
  4. Drag a PDF file from Finder into the Obsidian document window. A green backgrounded white cross appears at the cursor. Release the mouse key, the PDF file is not inserted

Expected result

The PDF file would appear in the document

Actual result


  • Operating system: Mac OS 12.2.1
  • Debug info:
    Obsidian version: v0.14.3
    Installer version: v0.12.12
    Operating system: Darwin Kernel Version 21.3.0: Wed Jan 5 21:37:58 PST 2022; root:xnu-8019.80.24~20/RELEASE_ARM64_T8101 21.3.0
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: off
    Plugins installed: 1
    Plugins enabled: 1
    1: Sliding Panes (Andy’s Mode)

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

I could repeat this problem with different PDF files and in multiple vaults

download and reinstall obsidian. Post a screen recording of this happening in the sandbox vault.

Done. Restarted the computer. Other PDF files worked. I tried this:

  1. Renamed the PDF file that wouldn’t import to RDF-LPG.pdf. I loaded that file successfully in the Obsidian document.
  2. Changed the name of the PDF file back to the original: “RDF Triple Stores vs. Labeled Property Graphs/ What’s the Difference?.pdf”. That file cannot be added to an Obsidian document.

You can’t use / in Obsidian for file names. That shouldn’t even be possible for the OS, unless it’s Unicode and not a real slash.

That would explain it, but MacOS seems not to have a problem with the / character. I don’t know why, but that’s what I am seeing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.