Pdf export with community plugin (table-extended) not working

I am working with the table-extended community plugin. It renders tables perfectly in the Obsidian viewer but when I export to pdf it renders the raw text (see images below). Is this a problem with Obsidian or the plugin?

Code used in example:

The following table shows ....
| | Col 1 | Col 2 |
| Row 1 | a | b |
| Row 2 | c | d |
[This is a table]
1 Like

Hi, I’ve just run into the same problem.
I thought a bit about it and this is my take: Obsidian exports to PDF using pandoc, which handles poorly tables with multi-columns cells. So, the first layer of the issue is that pandoc doesn’t allow such type of export; but even if it allowed that, it remains to be seen if the “language” the plugin uses is understandable by pandoc (second layer of the issue).

TL;DR: complicated matter, might be a problem with both the plugin and Obsidian.

As a (very poor) workaround: dump your extended table in another note, render/screenshot it, then put it where it belongs as an image. Far from optimal, but it works.


Update on previous answer: totally forgot that there is an option for this.
It is under Settings > Table Extended > Experimental: Export to PDF Support.
Toggling it on completely solved the issue for me; tables are exported to PDF as expected.


Worked perfectly. A few notes.

  1. Option was under Settings > Community Plugins > Table Extended > Settings
  2. I had to restart Obsidian for pdf rendering to work
1 Like

Still broken for me. I was using Advanced Tables and reported a bug to them here. I tried Table Extended, checked the experimental option as you suggested and it’s still broken. Really crazy output… even though it displays perfectly in Obsidian.
IMO, it’s a problem for Obsidian, not the plugins… there are other problems with PDF support in Obsidian.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.