PDF document

Steps to reproduce

  • Download any PDF file from Safari into my Obsidian vault using “Share → Save to files → (Choosing where vault is located) → Save”
  • Try to view that file inside Obsidian app

Did you follow the troubleshooting guide? [Y/N]


Expected result

To see the PDF file

Actual result

I see a black screen and “0 of 0” page count


Operating system: ios 15.0 (Apple iPhone)
Obsidian version: 1.4.8 (107)
API version: v1.3.7
Login status: logged in
Catalyst license: none
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

I tried it with A Simple PDF File - on my Windows app it displays correctly, but not on iOS

I can see the file using “Share → Quick view”, but not on Obsidian app

can you update iOS?

I’d like to, but more recent iOS versions are not compatible with other software I use

I think this due to the older iOS version you use. You could try to use the latest iOS 15.x that works with you other software. like 15.7.9.

I’m able to view that PDF.

I was able to reproduce the problem on the first PDF I tried in my vault, but it turned out to be a 0KB file that also doesn’t work in Quick Look. I haven’t explored further yet to see if I have any valid PDFs that won’t display.

I updated my iOS version to the latest available, and all PDF documents started appearing as they should

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.