Pasting URLs: Fetching Title->Site Unreachable


whenever I am pasting a link, it first shows [Fetching Title] so it can show the site title instead of the ugly looking URL. But since recently, instead of getting and showing the title, all I see now after a second is [Site unreachable]. When I click on the Site unreachable link then the browser opens that site of course because it is indeed reachable. I dont understand why now suddenly Obsidian is not being able to fetch the website’s title anymore.

Any ideas? Thank you!

Are you using the Auto Link Title plugin? It looks like another person also encountered this and reasoned that it was due to a weak Internet connection. Does that align with your experience?

Thank you I didn"t see that. However for me it doesnt matter if the internet connection is fast or slow, it always shows this after a second of trying to fetch it.

Also regarding the possible solution he suggested " increase the threshold maximum value for title fetching time." This is not in my options of the Auto Link title plugin :frowning:

Correct—the suggestion that poster made was to the plugin’s maintainer(s), not to a user looking to adjust their config.

The plugin maintainer recently introduced some changes related to scraping and CORS errors. You said “whenever I am pasting a link…”; does that mean you get [Site unreachable] every time? If so, could you look back for a link that worked for you in the past and try pasting it in again (not overwriting, but somewhere else in the note)?

Hello guys. Answering to your question @geoffb yes, I do get this every time. This worked in the past, but has been broken for a while not, unfortunately I don’t remember when it stoped working.

Looking at the console I get:

Access to fetch at ‘Pasting URLs: Fetching Title->Site Unreachable - #3 by Jas1’ from origin ‘app://’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. If an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.

Thanks for confirming, @henriquevalcanaia. Are you on the latest version of the plugin?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.