Pasting Clipboard Deletes Existing Text

Steps to reproduce

  1. Enable the Templates Core Plugin
  2. Copy to the clipboard a word or set of words
  3. Open a note in obsidian and place cursor immediately prior to an existing word
  4. Paste from the clipboard

Expected result

Word or set of words should be pasted before the existing word

Actual result

Word or set of words replace the existing word


  • Operating system: MacOS 10.15.7
  • Obsidian version: v0.11.13

Additional information

This only happens with Templates enabled. When Templates is disabled, I’m not experiencing this issue. This also causes an issue when attempting to paste in links - so, if I type [[]], place my cursor in the middle of the brackets, and paste, the brackets are replaced by the text I am pasting in.

Custom CSS is disabled, and I have tested this with all community plugins disabled (safe mode). When Templates plug in is disabled, this behavior doesn’t happen.

Both work as intended here (no overwriting). Not even when in “overwrite mode” (i.e., having pressed the Ins key before).

Linux Mint 20.1/Cinnamon, Obsidian 0.11.13.

The behavior looks like it varies too.

My page has this sentence: “Relies on improvised topic indexes called Maps of Content”

If I copy a single word “notes”, place my cursor at the start of the word “indexed”, paste the word “notes”, the pasted word replaced the space character between “topic” and “indexes”. I then undid my change, moved my cursor to the right (back in front of the word "indexes), then pasted the clipboard, the target word was replaced.

When I copy multiple words and do the same thing, “indexed” is always replaced.

I tried to reproduce with exactly the same sentences and words you said, and it works here without problems:

Maybe on your system, either

  • the clipboard contains “odd” characters, or
  • some plugin/theme/CSS introduces the problem?

I’d suggest

  • disabling all community plugins (simply set “Safe Mode” back to “On”—but remember which ones were enabled because when switching Safe Mode back to “Off” later, they will at first all be disabled),
  • disabling “Apply custm CSS”,
  • disabling any themes (set “Theme” to “None”),
  • disabling CSS snippets, and
  • removing any cssclass: lines from the front matter (if used).

Then try to reproduce the problem again. If it doesn’t occur anymore, try switching the above back on, one by one, until the error occurs again and you might find the cause.

P.S.: Sorry, just realized you said you tried this already. Maybe someone else can try to reproduce it on a Mac?

I experience it too. macOS Big Sur 11.2.3. Obsidian v0.11.13. I don’t have the Templates Core Plugin enabled and it’s present.

@Moonbase59 I disabled everything like you said and the bug was still present. Then I reloaded the note and it seems to go away. However, I’ll test it more and get back here with my findings.

I think it might be introduced by the update to the “Paste URL into selection” custom plugin. I updated it today and started to see this problem. When I disable this plugin, then it’s fine. Obsidian last update was 16d ago, so it shouldn’t be it.

Interesting. I don’t even have the “Paste URL into selection” plugin.

The community plugins I currently use are:

  • Advanced Tables 0.12.2
  • Better Word Count 0.6.1
  • Copy button for code blocks 0.2.1
  • Dataview 0.2.14
  • Extract Highlights 0.0.18
  • Hotkeys++ 0.2.5
  • Obsidian Leaflet 1.3.0
  • Shuffle 0.0.3
  • Templater 1.5.4

and I still can’t reproduce it, with or without these enabled.

Could it be a Mac problem, or maybe soomething on the Mac that interferes, like Alfred?

I’m back with more findings. The problem is back, even with the “Paste URL into selection” disabled. So I don’t really understand it right now. It does appear when I turn it on and go away when I turn it off, but now it appeared again with it disabled :confused:

However, I tried to test your “special characters in the clipboard” hypothesis. When I had this problem, it only appeared when copying from the Obsidian. When I copied some word from the browser and tried to paste it, then there was no problem with it. I tried to detect if there really are some special characters in either case with this tool (View non-printable unicode characters), but there was nothing special. Only the letters, no hidden characters. Any other ideas?

We have to wait for more people to check it, but yea, it seems to be Mac specific at the moment.

I have the same problem, and I’m on Windows. I checked all the community plugins and in my case, it’s clearly caused by the “Paste URL into selection”. But to see the difference between having it on and off I need to restart the whole app after disabling the plugin.

Thanks you. You need to report this problem to the author. We don’t take bug reports when third party plugins are involved.

Just wanted to jump on here and say a big THANK YOU to anyone who helped figure out it was the Paste URL into selection plugin causing this issue. I’m on Windows too and it was removing a space or character before everything I pasted, which was driving me crazy. I disabled all community plugins but the issue didn’t fix itself until after closing and reopening Obsidian. Very happy to have it all back to normal now. And with Obsidian mobile opened up to Insiders today, it’s like getting two awesome presents on the same day! Thanks again and take care.

1 Like