Pasted Images always stretched

What I’m trying to do

I want to paste an image which is small and keep the original size in the window instead of having it stretched to fill the whole width and having to manually adjust the width of every single image.

Things I have tried

Searched for answer but usually the solution is to use the resizing function e.g | 500. This is not a good solution for many images especially since their size was fine on first place…
Is there really no solution to just paste an image and show it as is ?

Would this plugin be helpful? GitHub - nicojeske/mousewheel-image-zoom

Thanks for the suggestion but it doesn’t look like what I need. All I need is just to paste an image in the shape and form it is already. Can’t believe this is not the default…Why would anyone think having an image stretched is useful is beyond me.

I don’t get stretched images in my vault, so why do you get that? Do you have some theme or plugins changing the appearance of your images? If so, that might be the cause of your issue, and a hint to where you need to locate the cure of it.


a few screenshots demonstrating what the issue is and what you want would be helpful here

1 Like

Thanks, I found the issue - I have “Minimal Theme Settings” and there is an option there “Maximise media”. Turning this off fixed the problem


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.