Pasted image not syncing from mobile

I pasted an image in mobile, and although it has been added, is visible and linked, and the vault is “fully synced”, the image appears nowhere on other devices.

Steps to reproduce

I cannot reproduce - when I paste another image in mobile, it gets synced and appears on eg desktop, as expected.

Did you follow the troubleshooting guide? [Y]

In the sandbox vault, the image does not appear either. New images do.

Expected result

Expect the mobile and desktop vault to be the same, so either the image on mobile disappears (bummer) or the image appears on desktop.

Actual result

The image exists on mobile, renameble, moveable, linkable. On desktop, the link gives and error and the image is nowhere to be found. Both report to be in sync. Both sync images. Both sync other images and text succesfully.

Environment

SYSTEM INFO:
Operating system: android 14 (samsung SM-S911B)
Obsidian version: 1.5.12 (134)
API version: v1.5.12
Login status: logged in
Catalyst license: none
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

I have the same issue using IOS. If I attach an image from my photos if syncs fine, but if I paste an image or PDF into the note, the note syncs but the image/PDF does not.

SYSTEM INFO:
Operating system: ios 17.5.1 (Apple iPad16,5)
Obsidian version: 1.5.12 (134)
API version: v1.5.12
Login status: logged in
Catalyst license: vip
SYNC INFO:
Vault ID: Redacted
Host server: wss://sync-20.obsidian.md
Device name:
Allowed file types: image, pdf
Allowed special types:
Ignored directories:
Prevent sleep: false

can you post a screen recording of this happening?
Where is the attached file being stored in your vault?