"Paste as text" not returning plain text

I’m trying to copy and paste code snippets and obsidian keeps changing special characters

I’m new to markdown based software so apologies if this is a basic question but im having a ton of trouble with code snippets, especially the character “%”.
using v0.12.3 on windows but also any version released from 5/08/2021 because i’ve had this issue since

as an example I have this templater snippet


copying from the web gives me this result:


copying from another note or the same note gives me this result:


for some reason if I type in something like “100%” and copy and paste that the result is as expected, it returns “100%”. I dont understand why “<%tp.file.title%>” is turning into a link when pasted? is it the dots? even things that aren’t templater commands will return a link


turns into


ctrl + v & ctrl + shift + v return the same result.
I’ve tried doing it from right click, and tried toggling auto-convert to html on and off. those are all the things I’ve tried from what I can see from any similar posts on the forums.

I’ve seen videos of people using obsidian and they seem to be able to copy and paste % and links with no issues. I really don’t understand what I’m doing wrong or if this is intended behavior and I’m just ignorant about it

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.