Page refresh problems with v0.16.2

Steps to reproduce

Starting with no tabs open, open a page into a tab. Then open other pages into the same tab. Occasionally — it’s hard to describe exactly when it will happen — the pages will stop painting fully. They will typically paint what is visible at the top of the page, but as you scroll down, the lower regions of the page are completely blank.

Expected result

I expect a page to display completely throughout the extent of its scroll range.

Actual result

Only the top of the page is repainted. As you scroll down, the page is blank.


  • Operating system: macOS 11.6.2
  • Obsidian: About Obsidian
    Version 0.16.2 (Installer 0.14.15)
  • Debug info:
    Obsidian version: v0.16.2
    Installer version: v0.14.15
    Operating system: Darwin Kernel Version 20.6.0: Wed Nov 10 22:23:07 PST 2021; root:xnu-7195.141.14~1/RELEASE_X86_64 20.6.0
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Minimal
    Snippets enabled: 9
    Restricted mode: off
    Plugins installed: 109
    Plugins enabled: 87
    1: Calendar v1.5.10
    2: Admonition v9.0.4
    3: Better Word Count v0.8.1
    4: Buttons v0.4.16
    5: Advanced Tables v0.17.3
    6: Collapse All v1.5.3
    7: Cycle through Panes v0.1.0
    8: CSV Editor v0.0.1
    9: Dataview v0.5.43
    10: Emoji Toolbar v0.3.1
    11: Excalidraw v1.7.19
    12: Find orphaned files and broken links v1.6.1
    13: Fullscreen mode plugin v0.1.2
    14: Hotkeys++ v0.2.7
    15: Icons v0.3.0
    16: Imgur Plugin v2.2.1
    17: Natural Language Dates v0.6.1
    18: PDF to Markdown v0.0.7
    19: Recent Files v1.3.3
    20: Show Current File Path v0.5.2
    21: Sort & Permute lines v0.5.1
    22: Tag Wrangler v0.5.3
    23: Templater v1.13.0
    24: Text expand v0.11.2
    25: Text Expander v1.1.1
    26: Workbench v1.6.1
    27: Note Refactor v1.7.1
    28: Things Logbook v0.1.16
    29: File Explorer Note Count v1.2.0
    30: Pluck v1.0.1
    31: PDF Highlights v0.0.4
    32: Timeline v1.1.0
    33: Daily Activity v0.4.0
    34: Sliding Panes (Andy’s Mode) v3.4.0
    35: Underline v1.2.1
    36: Plugin Changelogs v1.3.0
    37: Hotkey Helper v0.3.15
    38: Map View v2.1.1
    39: Filename Heading Sync v1.7.0
    40: Hotkeys for templates v1.4.3
    41: Mind Map v1.1.0
    42: Readwise Official v2.0.1
    43: Media Extended v2.11.1
    44: Number Headings v1.10.0
    45: Rich Links v1.1.0
    46: File path to URI v1.4.1
    47: Jupyter plugin v0.8.4
    48: Annotator v0.2.6
    49: QuickAdd v0.5.5
    50: Typewriter Scroll v0.2.2
    51: Workspaces Plus v0.3.2
    52: Editor Syntax Highlight v0.1.3
    53: Outliner v3.0.0
    54: Extract url content v0.12.1
    55: Dynamic Table of Contents v0.0.27
    56: Apply Patterns v2.1.1
    57: Quote of the Day v0.1.1
    58: Meld Calc v1.0.2
    59: v0.1.19
    60: Reveal Active File Button v2.0.1
    61: Highlightr v1.2.2
    62: Dictionary v2.21.1
    63: Zoom v1.0.1
    64: PlantUML v1.6.6
    65: Kroki v1.2.2
    66: Regex Find/Replace v1.2.0
    67: Icon Shortcodes v0.9.6
    68: Kanban v1.3.17
    69: Auto Note Mover v1.2.0
    70: Settings Search v1.2.0
    71: Tag & Word Cloud v1.3.2
    72: File Info Panel v1.2.5
    73: Creases v0.6.5
    74: Lapel v0.1.0
    75: Daily Notes Viewer v0.2.1
    76: Chat View v1.2.0
    77: Better CodeBlock v1.0.8
    78: Style Settings v0.4.11
    79: Vantage - Advanced search builder v1.4.1
    80: Omnisearch v1.5.2
    81: Obsidian Columns v1.2.0
    82: Text Format v1.8.1
    83: Minimal Theme Settings v6.0.2
    84: Contextual Typography v2.2.4
    85: Custom window title v0.3.5
    86: v1.0.4
    87: Raindrop Highlights v0.0.12

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Post a screen recording of this happening in the sandbox vault.