Page Preview sometimes doesn't properly render callouts

Steps to reproduce

(unfortunately I’ve been unable to reproduce this in the sandbox vault, although it does occur in my fault on the default theme with all custom css and plugins disabled. I’d be willing to provide my entire vault on request if it helps).

  1. Hover over a link to a note containing an admonition near the top

Expected result

A page preview from the core page preview extension, rendering correctly:

Actual result

The page preview is rendered with parts of the callout occluded:

This occlusion sometimes disappears when scrolling through the preview.


  • Operating system: Windows 11
  • Debug info:
	Obsidian version: v1.0.0
	Installer version: v0.15.9
	Operating system: Windows 10 Pro 10.0.22623
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

Sorry about the lack of details to reproduce this bug, I tried for a while in sandbox vault to reproduce it but I just couldn’t make it happen. I wouldn’t normally have submitted a bug without reproduction steps, but this really sucks for my notetaking strategy given how often I put important information that it would be useful to reference from other notes in callouts. Again, if requested, I’d be willing to email the devs my entire vault – it occurs there consistantly.

Did you restart Obsidian after disabling the plugins? That’s needed to fully unload them.

I didn’t, but after doing so this still occurs:

Not sure how much this helps but just from my own debugging this problem goes away if I open Developer Console and use the inspector to disable the CSS variable declaration --radius-m: 8px.

1 Like

Yep, I’ve now worked around this by adding a css snippet:

.popover {
  border-radius: 0px

It’s kinda ugly but it works!

can you attach a copy of file where this happens?