Page preview Cmd/Ctrl still follows reading view settings for Callouts and tables in editor

Steps to reproduce

  1. I turned on Restricted Mode, and I used the core plugin “Page Preview”, and I set as the image shows.

  2. I insert a link in Callout like these images.



Expected result

When I move to the link without “Ctrl”, It shouldn’t show the Preview result.
And I can preview when I click “Ctrl”.

Actual result

It shows Preview Result whether I click “Ctrl”, which means I always can preview the content when I move to the link, but it’s not what I really need.


Restricted Mode
Default Theme with CSS

Additional information

you have to enable for the reading view as well, that’s how the callout is rendered.

I just want to preview directly in Reading View, and preview with ‘Ctrl’ in editing view.
Do you mean that can’t be achieved in Callout because of Callout’s unique mechanism?

yes, that’s what I mean.

The same is going to be true for tables.

@Josr It’s just a hacky workaround, but I wrote this simple plugin to fix this: GitHub - RyotaUshio/obsidian-page-preview-helper