Outlines containing LaTeX blocks don't render indent or icon right in edit but do in read

Steps to reproduce

Lecture notes

  • ETS (abbreviation for exponential (time) smoothing) has several criticisms (myths)
    • It’s eclipsed by machine learning
    • It’s just ARIMA
    • There’s nothing new
  • He goes over several of the early model
    • Simple exponential smoothing (SES) has an ARIMA (0,1,1) model $$\hat y_{t+1} = \hat\alpha y_t + (1-\hat\alpha) \hat y_t$$where $y_t$ are the observed data, $\hat y$ is the forecast data, and $\hat \alpha$ is the smoothing parameter. In forecasting, it holds the last forecast value.
    • Linear trend (Holt’s method) has an ARIMA (0,2,2) model $$\begin{align}
      \hat y_{t+1} &= \hat l_t + \hat b_t \
      \hat l_t &= \hat l_{t-1} + \hat b_{t-1} + \hat \alpha e_t \
      \hat b_t &= \hat b_{t-1} + \hat \beta e_t
      \end{align}
      $$ where $\hat l$ is the level of the series, $\hat b$ is the trend component, and $\hat \beta$ is the smoothing parameter. The forecast holds the linear trend estimated from the last forecast value
    • Continued bullet list

The above renders incorrectly in edit, but correctly in read - the last bullet should be indented by 1 level, but it’s not in edit. Trying to correctly edit gives bad render no matter what I do - wrong column, off by 1 space, or wrong bullet icon. Read mode, however, renders correctly.

Did you follow the troubleshooting guide? [Y/N] Y

Expected result

I expect the last line to be indented to the 2nd level and with the standard filled circle bullet icon in edit preview mode. It only looks right in read mode.

Actual result

Wrong indent. Tabbing over changes bullet icon to ‘-’ and puts in wrong column (off-by-one-space). The wrong render is also seen in sandbox vault.

Environment

SYSTEM INFO:
Obsidian version: v1.5.3
Installer version: v1.4.16
Operating system: Windows 10 Pro 10.0.19045
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 6
Plugins enabled: 4
1: Dataview v0.5.64
2: Remember cursor position v1.0.8
3: Text Format v2.2.9
4: Advanced Tables v0.20.0

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

Edit preview mode:


Read mode:

You need to put block math in its own block and not use it inline

text
$$
math
$$
more text

this $$will$$ create problems

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.