Outliner plugin doesn't work?

Hi all, could anyone suggest what I’m doing wrong?

I have the Outliner plugin installed, but I don’t get the ‘dot’ that you click on.

Have deactivated the built-in Outline feature, still not working.

It says, ‘Styles are only compatible with built-in Obsidian themes’, des that mean the default style?

Either way it still doesn’t want to work. What am i missing?

Thanks, Smithy

Outliner - Obsidian

Outliner plugin is primarily meant to be used with bullets. so your notes should look like this

- Outliner
    - sub bullet 1
        - sub to sub bullet 1
    - sub bullet 2

with that you’ll see the dot to click on. but note that you also need Zoom plugin (by the same dev) for you to have a function on click (which is zooming into the bullet)

p/s: u can use outliner without bullet, but in reading view it will all just rendered unindented.

Thanks @efemkay, I installed the Zoom plugin, still no joy.

This is what I have:
Untitled

You can see, there are no bullets, Only the Arrow (on hover). Also, you can see the cursor 2nd from bottom line over on the left.
I have the built-in Outliner plug-in disabled (have tried both with and without it). I have returned to the default Theme, in case the community theme wasn’t compatible. I’ve watched as many Youtube tutorials as I can find, and cannot work out why it won’t behave in the way everyone is saying it should???

I’ve just opened LYT Kit 6, and it has the bullets and zooms just fine (with Outline core plug-in on, Outliner and Zoom installed), I even checked which Theme it has, and tried that, still no joy!!!

Any one can help please?

Cheers, Smithy

Hi @Smithy, it looks like maybe you’re prefixing each item in your outline with tabs. In Obsidian they must be prefixed with a dash in order to be treated like an outline.

Also, I believe the Zoom plugin also requires dashes and only works in source mode or live preview mode.

An example is below – source mode on top, reader mode on the bottom:

Version 2.2.5 of the plugin works. Version 2.3.0 does not.

Check to see what version of the plugin you’re using, downgrade to 2.2.5 if necessary.

Here’s how to downgrade:
Go to the releases page, open up the 2.2.5 section, click on main.js, manifest.json, and styles.css to download them to your computer, then move those 3 files to your vault/.obsidian/plugins/obsidian-outliner directory. That will overwrite the 2.3.0 files with the 2.2.5 version and you’ll be back in business.

Can’t thank you enough guys @Craig and @LeslieP, that worked!

One thing I still don’t understand, I can’t go in more than the one indent. How to I create further indents, or child er, whatevers?

2022-06-22-Window

Many thanks :heart_eyes: :heart_eyes: :heart_eyes:

@LeslieP
Leslie I did that but it seemed to respond the same, after reboot and all.

So, working well, except I can’t get it to go in more than one ‘indent’.

I take it, you use the Tab key to get the indent, and then use the ‘dash’ key for the Bullet. After the one Tab key, it wouldn’t tab in any more.

You should be able to tab “another line” to go under “what about”. Do you have the 3 “enhance” options enabled in the plugin settings? Try disabling the other things, just to verify it works ok. I have only the three “enhance” options enabled on my system, and it works well with my Blue Topaz theme. Enabling those options gets all mixed up with what my theme is doing.

In general - you’re gonna have to tweak and try different things depending on your theme - it’s all a bit flaky since obsidian isn’t an outliner, no matter how much we want it to be.

The outermost line has no indentation. Each level of indentation should have an additional tab or four spaces before the dash.

So for example:

  • The outermost line should be: (dash) (space) Text
  • First indent should be: (Tab or 4 spaces) (dash) (space) Text
  • Second indent should be: (2 Tabs or 8 spaces) (dash) (space) Text

It might be clearer to see in a text editor:

It’s funny isn’t it. Some things in Obsidian are brilliant and not so good in Logseq, some things are brilliant in Logseq but not so good in Obsidian.

Thanks for your time and words both, I’ll have a bash at it and let you know how it goes.

Many thanks, smithy

2 Likes