Outline pane does not stay collapsed and scrolls while typing

Steps to reproduce

video in MKV format you can watch to see the bug live using the Obsidian Sandbox with version 1.5.3:

Step 1: Open Obsidian Sandbox
Step 2: Create a new note
Step 3: Add 350+ Heading 3 (###) to the note (make sure each heading has it’s own carriage return)
Step 4: Open the Outline pane for the newly created note on the right hand side.
Step 5: Scroll to the bottom of the Outline pane for the newly created note
Step 6: Scroll to the bottom of the newly created note
Step 7: Add a new Heading 3 (###) and start typing your new heading title…
Step 8: Watch how the bug in the Outline pane automatically scrolls up and around.
Step 9: The newly created Heading 3 (###) is no longer showing at the bottom of the Outline pane where the newly created Heading 3 (###) was just added.
Step 10: Try and update the Heading 3 (###) you just added or even add another Heading 3 (###) below and the Outline pane scrolls up and around again while you are typing… very disorientating.
Step 11: The updated or newly added Heading 3 (###) will no longer be in view in the Outline pane.

Did you follow the troubleshooting guide? [Y]

Yes the steps above are reproduced in the sandbox vault with no community plugins enabled.

Expected result

When I type a new or are modifying an existing Heading 3 (###); the expected behaviour would be for the Outline pane to stay at the same position with the new or modified Heading 3 (###) in view within the Outline pane.

Actual result

When I type a new or are modifying an existing Heading 3 (###); the actual behaviour is the Outline pane to scrolls around and no longer has the newly added or modified Heading 3 (###) in view anymore within the Outline pane.


Obsidian version: v1.5.3
Installer version: v1.5.3
Operating system: Windows 10 Pro 10.0.22000
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

I’ve added a video for your reference:

2024-01-13 15_11_06-file.io - Obisidan Outline view

Thanks, we are aware of this.

Thank you for your quick response.

Can you advise when the bug will be resolved and what can be done in the meantime?

Video of reproducing the bug since file.io links are not allowed:
2024-01-13 14-55-52.zip (2.9 MB)

I don’t want the outline to unfold after I start typing, its infuriating. I’d like it if it could remember the fold position as well.

Things I have tried

The community Plugin “Quiet Outline” used to solve this but since the recent update its been broken.

What is broken in Quiet Outline?

There’s a “Default Expand Level” function that doesn’t work (the outline is always expanded all the way whenever I open any note, and when I fold the outline everything will just auto-expand when I start typing in the note)

There is an Auto Expand toggle in Quiet Outline settings, have you tried that?

Yes, doesn’t work

Dang, I’m stumped in that case…

Then again, I am not running the latest version of Obsidian.

Maybe I’ll try going back to the last version, I think quiet outline was working back then. I don’t know if thats possible but

I would do that as well… And yes, it is possible, you get the version you want from the github

What do I click on to download the version I want…?

Scroll to the version you want, click the assets dropdown, then based on your OS download the file that works on it

I’m not sure. Did you use quiet outline or core outline plugin? Quiet outline doesn’t react to normal typings, it only change after header editing.

I’m using obsidian v1.5.3 now but can’t reproduce the issued problem.

I’m on the same version but I still have the issue. I have quiet outline installed but I tried unistalling it and it didn’t change anything

If you can show me how to fix my issue without needing to use Quiet Outline that would be a godsend, I figured out I just didn’t have Quiet Outline on lol. Now I do but I like how the vanilla Obsidian outline looks much better

moved to bug reports