Opening notes registers as a file change in GitHub Desktop

Things I have tried

I have an Obsidian vault in GitHub version control but whenever I navigate from one note to another in the Obsidian UI the note I left registers as being changed in GitHub desktop but no content changes are found. This only occurs on one of the machines I cloned the repository to so I’m wondering if it is an Obsidian configuration difference between the vault on each machine.

What I’m trying to do

My expectation is that looking at a note without editing the text would not result in changes being logged by GitHub desktop.

For reference my .gitIgnore file is as follows:


The first line is present because I’m using MK Docs to publish part of the vault online: GitHub - jobindj/obsidian-publish-mkdocs: A Template to Publish Obsidian/Foam Notes on Github Pages (uses MkDocs)
Assuming the .gitignore file is ok for Obsidian settings I don’t think the first line is relevant.

Any suggestions about where to look would be appreciated.

After looking into this further I believe the issue related to line endings in my local repository. I’m working on Windows. The issue only seems to arises in vaults where my line-endings are CRLF. I check that by running the command git ls-files --eol in tracked folders. Folders with LF line endings work fine. At present I’m unsure how the issue arose or how to resolve it locally and then sync the changes.

I ran into a similar issue where I sync a vault between Mac and Windows machines, but I was able to work around it by disabling the autocrlf conversion on my windows machine only. So my .git/config file has this:

	autocrlf = false

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.