Opening links from a pinned tab doesn't use existing non-pinned tab like it used to.(single pane)

Steps to reproduce

In single pane view click links from a pinned tab. This will open multiple new tabs instead of opening in an existing non-pinned tab like it used to.

Did you follow the troubleshooting guide? [Y/N]

Y - I tried in Sandbox and in restricted mode.

Expected result

New links should open in existing non-pinned tabs instead of opening a new tab for every link. This worked in 1.2.8. I see that it was supposed to be reverted in 1.3.4 but that doesn’t seem to be the case. At least for single pane. It works in split pane.

Actual result

Links from pinned tabs in single pane view open new tabs every time instead of using existing tabs.


Additional information

Installed and installer version both show 1.3.5
A fresh install of 1.2.8 fixes the issue.

It uses existing tabs in split pane mode but not single pane mode. This used to work with single pane in 1.2.8 before the change. It says it was reverted in 1.3.4 but I’m running 1.3.5 and it still does this. I confirmed with another discord user that it behaves the same for them in single pane mode. This has unfortunately broken my workflow.

Seems this was the original thread about this issue but it’s closed saying it was rolled back. It seems to only be partially rolled back.