Opening a PDF with Zathura locks Obsidian

Steps to reproduce

Export a note to PDF with Zathura as the default PDF reader.

Expected result

PDF file opens in Zathura and able to continue using Obsidan with Zathura open.

Actual result

Obsidian locks up and remains frozen until Zathura is closed.


  • Operating system: Ubuntu 20.04
  • Obsidian version: AppImage 0.11.3

Additional information

I can’t reproduce this with the AppImage on Ubuntu 18.04. Do you have any other steps? Can you post a video?

Thanks for the quick reply. There are no other steps. What is best practice for creating and adding videos on this forum?

Depending on how long they are, you can also go for a GIF (I record mine with Peek) and just drag and drop here. Otherwise, there are no fixed instructions.

1 Like

Just a quick update. I normally use i3. Since you said it worked for you on Ubuntu I just did a quick test exporting a PDF within Plasma and it works fine with no lock-up. So there is obviously something with how i3 handles the operation that is causing the lock.

I am also on i3, so I don’t think that is the root of the problem

Here’s a gif:

Does this happen if you have CSS off?

Sorry, what do you mean by CSS off? If you mean “Apply custom CSS” I never had that turned on. If I set the theme to none and turn on safe mode to disable community plugins the issue still happens.

I’ve also double-checked the desktop entry, xdg-mime, and xdg-open and all looks and works as it should.

Yeah, I mean turning off the custom theme and any snippets you might have.

Aye so still happens when turn all of that off. I also tried with a new empty vault and same issue. I don’t experience this issue with any other applications, e.g. if I use the markdown-pdf extension in vscode it opens the PDF without locking vscode, same with vim and the vim-pandoc plugin.

This seems weird to me, it might be something with how your i3 is configured? Otherwise it would happen in plasma too as you suspected. Could also be the versions we are using that are different.

I use i3-gaps from the Regolith repo - I don’t install anything else from the repo.

Is there a way to view the file operation Obsidian runs to open the PDF? That might help narrow down what is causing the issue.

Edit: I’ve tried setting an event listener breakpoint on click then stepping through the execution but my knowledge of electron/js is virtually nil, so I couldn’t figure out what is the code that is calling the file open operation.

Another quick update - I changed the default PDF reader to Okular to test whether the issue was related to Zathura. However, the same issue occurs with Okular.

Oh, and if right-clicking a picture and selecting to open in default application Obsidian locks up as well until the application the photo is opened in is closed.

OK, narrowing down the issue slightly. I just installed the flatpak version of Obsidian and the issue does not occur with it.

lol I don’t know what the odds are, but I’m also using the i3-gaps version from regolith. My guess is that there is something different between our versions that is causing the issue, since I can also open Okukar the same way I do with Zathura.

Any chance it’s due to an old installer from Obsidian?

I downloaded the latest AppImage just a couple of weeks ago. It’s weird that the Flatpak doesn’t have the issue given desktop integration isn’t always great with them - e.g. I’ve never managed to get theming to work with Flatpaks.

I am gonna move this help.

Yeah, I’m surprised it works in the flatkpak but not the AppImage. I’m wondering if your compositor could have something to do with this, what are you using?

I’m using compton - just killed it and tried exporting and still have the same issue.