One workspace is occasionally replaced by another with Obsidian sync

Once you’ve done the above, delete everything above this line.
I use Obsidian on a work laptop, a personal laptop, and two mobile devices. I have several workspaces configured in my primary vault.

For the last couple of months, I’ve noticed that one named workspace is intermittently replaced by the layout of another workspace. I haven’t been able to reliably reproduce it. As near as I can tell right now, the currently active workspace on one laptop will be replaced by the currently active workspace on the other laptop as I switch back and forth. (But, I haven’t been able to absolutely verify this. It only occurs occasionally so I haven’t been able to identify all the before and after conditions to see what the pattern is.)

Steps to reproduce

I can’t reliably reproduce it yet.

Expected result

Workspaces should sync between devices without swapping layouts.

Actual result

Occasionally the layout of one workspace replaces the layout of another. I then have two workspaces with the same layout.


  • Operating system: Windows 10
  • Debug info:
    Obsidian version: v1.1.11
    Installer version: v1.1.9
    Operating system: Windows 10 Pro 10.0.19045
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Minimal v6.1.19
    Snippets enabled: 1
    Restricted mode: off
    Plugins installed: 32
    Plugins enabled: 27
    1: Omnisearch v1.9.1
    2: Outliner v4.2.1
    3: Pandoc Plugin v0.4.1
    4: Pane Relief v0.4.1
    5: Periodic Notes v0.0.17
    6: Quick Explorer v0.2.7
    7: Quick Switcher++ v2.3.5
    8: Relative Line Numbers v2.0.1
    9: Style Settings v0.4.12
    10: Tag Wrangler v0.5.6
    11: Templater v1.16.0
    12: Vault Statistics v0.1.3
    13: Workspaces Plus v0.3.3
    14: Calendar v1.5.10
    15: Emoji Toolbar v0.3.2
    16: Filename Heading Sync v1.8.0
    17: floating toc v2.3.0
    18: Minimal Theme Settings v6.1.1
    19: Natural Language Dates v0.6.1
    20: Note Refactor v1.7.1
    21: Obsidian Link Converter v0.1.4
    22: Obsidian42 - Strange New Worlds v1.1.2
    23: Creases v0.6.6
    24: Dataview v0.5.53
    25: Dictionary v2.22.0
    26: Advanced Tables v0.18.1
    27: Commander v0.4.9

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I’m moving this to Help for the time being. Bug Reports are supposed to be tested without community plugins. You have many installed, including at least one that is related to workspaces.

Another thing to check is inside your .obsidian folder, and see if there are any conflicted copies of any workspaces files. Just to check, you are only using Obsidian Sync right? Not a mix of any other sync tools?

1 Like

Yes. I’m only using Obsidian Sync.

I appreciate the desire for testing without plugins installed. And, as you say one of the plugins that I have installed affects workspaces.

However, it is an intermittent problem. I haven’t been able to consistently replicate it in my normal environment. While, I have tried to reproduce it consistently, I haven’t been able to yet.

Another possible factor that recently occurred to me is mobile devices. Workspaces are synched to mobile devices and I do occasionally open Obsidian on my phone without closing it first on a computer.

I created the bug report to inform the Obsidian team, to see if anyone else has the problem, and to give me a place to store updates as I gather more information.

It also occurred to me that there may be something about the structure of how workspace layouts are persisted that may make it susceptible to causing the problem. I haven’t had time to dig into it enough to understand it. A more knowledgeable set of eyes might be able to see a potential weakness – in light of this report.

WRT updates:
I saw some posts in Discord that indicated that the workspaces are only synced on startup and that it was a poor practice to have Obsidian open on multiple computers at the same time (something I was doing).

For around a week or so I’ve had only one instance of Obsidian (with the exception of running it on my phone occasionally) running at any one time. This problem still occurs so it isn’t due to having multiple instances open simultaneously (though that may well aggravate it).

It still seems likely to me that it may be related to having different active workspaces on my devices (2 computers and a phone, so far) when I open and close Obsidian and the sync occurs.

WRT the Workspaces Plus Plugin:
IMO, the Obsidian team should consider sherlocking its features. While it makes it marginally easier to switch between workspaces, what I really find valuable is the “Auto save the current workspace on layout change”.

Which of course, could also be the source of my problem. :smiley:

Thanks for the quick response. :slight_smile:
Absolutely love Obsidian – and I’ve tried a variety of similar products over a number of years. I particularly appreciate the rapid evolution of the product - even though that results in issues from time to time.

Everyone on the team is doing a superb job.

1 Like

Thanks for the updates and additional info.

And did you check inside your .obsidian folder for any potential conflicted files, especially the workspace json files?

I also have multiple instances of Obsidian open. I do my best, but I often forget to close it when dual booting too. And Dropbox (which I use) will frequently conflict those files in particular. I haven’t tested Obsidian Sync thoroughly enough.

Maybe you could try disabling the Workspaces Plus just for a while to test. Or turn auto-save off, if you can. And then if you can narrow it down to that, maybe a fix can be pushed out by the plugin author.

I’ve looked at the .obsidian folder files in detail – trying to track down another intermittent problem that occurs in just one vault on just one computer. :frowning:

Haven’t seen anything amiss as far as the existing files are concerned. I did delete some plugin files that I was no longer using, but apparently didn’t clean up their files when I uninstalled.

Will play around with the Workspaces Plus settings when I get a chance.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.