Once closed, Obsidian won't launch unless I restart KDE Plasma shell

Steps to reproduce

  1. Open Obsidian by clicking on the icon.
  2. Close Obsidian by clicking on the X in the upper right corner.
  3. Try to open Obsidian again by clicking on the icon.

Expected result

Obsidian should launch, open the last used vault/note, etc.

Actual result

Obsidian’s icon animation looks like it’s loading, but the window doesn’t appear. Obsidian creates several processes visible in system monitor. The processes eat a small amount of memory but no CPU usage is seen.


  • Operating system:
    Debian 11 with KDE Plasma desktop environment
  • Debug info:
    From Obsidian:
    Obsidian version: v0.15.9
    Installer version: v0.14.15
    Operating system: #1 SMP Debian 5.10.136-1 (2022-08-13) 5.10.0-17-amd64
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 2
    Restricted mode: off
    Plugins installed: 1
    Plugins enabled: 1
    1: Obsidian Git v1.31.0

From Plasma:
Operating System: Debian GNU/Linux 11
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.0-17-amd64
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-6200U CPU @ 2.30GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520

Additional information

I’m able to fix this issue by doing:

  1. End all processes named “obsidian” in system monitor.
  2. Restart KDE Plasma shell:
kquitapp5 plasmashell && kstart5 plasmashell
  1. Clicking on the icon of the app will now have it launch as expected.

Sorry that the debug info has the plugins and snippets - this issue continues even without them.
I don’t know how to dump the names of the processes in an elegant way. I’ve took screenshots of some and put them in this imgur album. I didn’t screenshot those with repeating titles, as most of them simply have the name “obsidian --enable-crashpad”.

I don’t experience this issue with any other application, otherwise I’d take this to some Plasma related forum. Let me know if this should go there anyways, or if there’s any other debug info I should give that I skipped by accident.

we only provide support for the appimage and snap package. Does it happen with those?

Download and reinstall obsidian.

Weirdly Obsidian application does not show up in Discover app under “Installed”, even though I’ve installed the .deb by right-clicking on it and opening it in Discover.
I’ve manually purged it from the system by using find / -name obsidian, and then installed Obsidian 0.15.9 with dpkg: sudo dpkg -i obsidian_0.15.9_amd64.deb. I’ve tried opening and closing it several times now and it works as expected, so I suppose that resolved it.
I didn’t know deb is not supported. Perhaps it could use a warning on the download page.
I’ve also tried appimage while waiting for the other file to download. It also works as expected but is noticeably slower. I will stick to deb.
Thank you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.