On macOS, top of Obsidian window clips

Steps to reproduce

Open Obsidian. Use it for a while. At some point — I cannot precisely determine when it occurs or what causes it to occur — the top of the window will clip, and any of the controls at the top of the window will be only partially visible and unclickable.

Expected result

I would not expect that this would ever happen.

Actual result

Environment

  • macOS 13.2
  • Debug info:

SYSTEM INFO:
Obsidian version: v1.1.16
Installer version: v0.14.15
Operating system: Darwin Kernel Version 22.3.0: Thu Jan 5 20:48:54 PST 2023; root:xnu-8792.81.2~2/RELEASE_ARM64_T6000 22.3.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Minimal v6.1.19
Snippets enabled: 12
Restricted mode: off
Plugins installed: 129
Plugins enabled: 104
1: Admonition v9.2.1
2: Better Word Count v0.9.4
3: Buttons v0.4.19
4: Advanced Tables v0.18.1
5: Collapse All v1.5.3
6: Cycle through Panes v0.1.1
7: CSV Editor v0.0.1
8: Dataview v0.5.55
9: Emoji Toolbar v0.4.0
10: Excalidraw v1.8.19
11: Find orphaned files and broken links v1.8.0
12: Fullscreen mode plugin v0.1.2
13: Hotkeys++ v0.2.7
14: Icons v0.3.0
15: Imgur Plugin v2.2.1
16: Natural Language Dates v0.6.1
17: Recent Files v1.3.5
18: Show Current File Path v0.5.2
19: Sort & Permute lines v0.7.0
20: Tag Wrangler v0.5.6
21: Templater v1.16.0
22: Text Expander v1.1.1
23: Workbench v1.6.1
24: Note Refactor v1.7.1
25: File Explorer Note Count v1.2.0
26: Pluck v1.0.1
27: PDF Highlights v0.0.4
28: Timeline v1.1.0
29: Daily Activity v0.4.0
30: Underline v1.2.1
31: Plugin Changelogs v1.3.0
32: Hotkey Helper v0.3.15
33: Map View v3.0.1
34: Filename Heading Sync v1.8.0
35: Hotkeys for templates v1.4.3
36: Mind Map v1.1.0
37: Readwise Official v2.0.1
38: Media Extended v2.11.1
39: Number Headings v1.13.0
40: Rich Links v1.1.0
41: File path to URI v1.4.1
42: Jupyter plugin v0.8.5
43: Annotator v0.2.10
44: QuickAdd v0.12.0
45: Typewriter Scroll v0.2.2
46: Workspaces Plus v0.4.16
47: Editor Syntax Highlight v0.1.3
48: Outliner v4.2.1
49: Dynamic Table of Contents v0.0.27
50: Apply Patterns v2.1.2
51: Quote of the Day v1.0.1
52: Meld Calc v1.0.2
53: Hypothes.is v0.1.19
54: Reveal Active File Button v2.0.3
55: Highlightr v1.2.2
56: Dictionary v2.22.0
57: Zoom v1.1.1
58: PlantUML v1.6.6
59: Kroki v1.2.3
60: Regex Find/Replace v1.2.0
61: Icon Shortcodes v0.9.7
62: Kanban v1.5.2
63: Auto Note Mover v1.2.0
64: Settings Search v1.3.6
65: Tag & Word Cloud v1.3.2
66: File Info Panel v1.3
67: Creases v0.6.6
68: Lapel v0.1.0
69: Chat View v1.6.0
70: Better CodeBlock v1.0.8
71: Style Settings v1.0.3
72: Vantage - Advanced search builder v1.4.2
73: Omnisearch v1.13.0-beta.1
74: Obsidian Columns v1.4.0
75: Text Format v2.2.1
76: Minimal Theme Settings v6.3.1
77: Contextual Typography v2.2.4
78: Custom window title v0.3.5
79: Diagrams.net v1.0.4
80: Raindrop Highlights v0.0.14
81: Duplicate Line v1.2.0
82: Icon Folder v1.7.0
83: Linter v1.10.3
84: Remember cursor position v1.0.7
85: Obsidian asciimath v0.5.3
86: Plugin Update Tracker v1.4.5
87: Table of Contents v0.1.4
88: Commander v0.4.9
89: Book Search v0.5.9
90: Janitor v1.1.0
91: PodNotes v2.10.7
92: DB Folder v3.3.2
93: Spaced Repetition v1.10.0
94: Tasks v1.25.0
95: Mermaid Tools v0.1.1
96: Metadata Menu v0.4.21
97: Obsidian_to_Anki v3.4.1
98: Text Extractor v0.4.3
99: Things Logbook v0.1.16
100: Multi-Column Markdown v0.7.7
101: Supercharged Links v0.9.3
102: Calendar (Beta) v2.0.0-beta.2
103: Dynamic Highlights v0.3.1
104: Console Markdown Plugin v1.0.2

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

Reloading Obsidian restores the window without any clipping. However, if you continue to use the app, the clipping will return.

Here is a screenshot of the window after it has started clipping:

Here is a screenshot after reloading Obsidian:

Note that this behavior occurs whether the window is full screen or not. I do have Stage Manager enabled. I will investigate if disabling Stage Manager has any effect and report my findings.

Download and reinstall Obsidian.

I am gonna move to this BR to help section because it’s vague, non reproducible reliably, and you are using custom theme and custom plugins. We’ll see if we get more reports.

I’m sorry, but what is vague about this? It is a real issue. Yes, I am using a lot of plugins including a custom theme, but isn’t that the point with Obsidian?

As far as this issue goes, what move information can I provide you? I created the issue in good faith and provided you with as much information as I could including screenshots. If you need something more, let me know. I am happy to work with you on this.

I’ve used Obsidian for a long time. It’s a fantastic tool, and, for the most part, I am extremely happy with it. I recommend it to others daily. However, I am disappointed by your dismissive reply.

How about we start with a simple question: What plugin might be responsible for the main Obsidian window frame not drawing correctly? Is it likely a custom theme? I am using the Minimal theme which has 400K downloads. I also use the Style Setting plugin to customize Minimal. Style Settings has 300K downloads. It seemly unlikely that such commonly used plugins could account for this behavior without lots of others reporting the issue.

No, it’s not dismissive. You yourself said you can’t precisely determine when it occurs or why. Hence, the issue is vague and non-reproducible. This wasn’t a critical judgment against you. It was an explanation of why it got moved to Help.

  1. I’ll repeat what WhiteNoise said because this should be your first step: Download and reinstall Obsidian. Your installer is extremely out of date. This might already fix the problem.

  2. After that, make sure all your plugins and themes are updated too. And make sure you’re using a theme that has been fully updated to support Obsidian 1.0+ which had a major theme engine overhaul.

  3. Bug reports need to be tested with no community plugins or custom themes. There is no official support for 3rd party plugins. When you turn off Restricted Mode, you take full responsibility for the effects that plugins have on your vault. So it’s up to you (or anyone in the community who has seen the same problem) to figure out which plugin or theme might be causing the issue.

You can turn off plugins in groups, or there is a plugin that can help with this called “Divide & Conquer” which helps bulk enabling/disabling of plugins. That can help you zero in on the problem plugin.

OK, reinstalled Obsidian and have the latest installer. See https://share.cleanshot.com/vhBbK23h+. The problem still persists. I guess the next step is to disable plugins and try re-enabling them one-by-one.

Using the Divide and conquer plugin, might help you locate the culprit a little faster.

This plugin helps you to enable and disable groups of plugins, and it also has some documentation on how to narrow down the search in order to quickly locate the offending plugin.